1

Within the Text import Wizard, the default delimiter is TAB. Is it possible to permanently modify this default to be a comma?

Don't be tempted to think that this is a duplicate question. Neither this nor this is the same question, nor do they give clues to the answer.

How do I get the control indicated below to be selected by default? That way, I could just open a CSV file and hit "Finish" with no further clicking.

screenshot

Regardless of the file extension (in this case, I'm mostly concerned about .CSV files) or the delimiter (in this case, I'm looking at commas since that's what the 'C' in CSV stands for), when I select File / Open (from within Excel) the Text Import Wizard always selects TAB as the delimiter. Of course, I can remove the check and place a check by the comma, but can I make that solution permanent?

No modification of Control Panel Regional Settings seems to work. It's very frustrating as I would never use anything other than a comma in a file of "Comma Separated Values"! I'd certainly never use the tab character in the creation of a table in a text file.

  • 3
  • 1
    See this answer – DavidPostill Jul 17 '16 at 12:30
  • Definitely not a duplicate of this question. It's a difficult question to phrase. I know how to change away from the default settings for my current session. I'd like to permanently change the default. I'm also concerned tat I'm doing something wrong. Why would TAB be the default for a CSV file? Surely that would be (if such a thing existed) a TSV (Tab Separated Values) file? Why the hell is "tab" the default separator for a CSV file? Thanks for trying to get to grips with my pain!! – KDM Jul 17 '16 at 21:36
  • It isn't clear how what you're asking is different. The question in your mind might be different, but unless you can describe the difference better, you would attract the same answers. – fixer1234 Jul 18 '16 at 4:07
  • Having read more thoroughly, this question is, indeed, a duplicate and the answer is given. I concede that I skimmed over the answer containing the macro thinking that this was an unlikely solution to an obvious problem, which ought to be solvable with a checkbox! C'mon, Microsoft: the "C" stands for "comma". – KDM Aug 7 '16 at 9:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.