1

Using Windows XP ISO in VMWare Workstation Player 12. No matter what I do, I cannot connect to Internet from the Virtual OS.

What I have tried

  1. Disabled Windows XP Firewall
  2. Disabled and Enabled the Network
  3. Tried NAT connection, Tried Bridged connection
  4. Scrapped the virtual VM and re-installed Windows XP in VMWare Player
  5. Can ping www.google.com, but cannot browse to www.google.com

How to troubleshoot this?

By the way, I have Kali Linux 2 ISO in same VMWare Workstation Player 12 and can connect to Internet fine.

Update

Tried the Windows VM, but get error

enter image description here

Update 2

I disabled firewall on Windows XP VM with

netsh firewall set opmode mode=disable profile=all

I can access some websites (CNN, FoxNews), but not others (Google, Facebook).

I even opened ports 80 and 443 per the following. How to troubleshoot?

enter image description here

Fixed it

I ended up downloading and installing Firefox. Now I can access all the websites.

Thank you SuperUsers, you guys are awesome!!!

  • Did you try with a pre-installed version of XP? It seems here there is an image with windows xp preinstalled. After you rise you defences, you may try to download one of the preinstalled vdi/images you can find on internet and run it. If it works it means you have to see what inside your XP stops the communication with internet. If not it's probably outside. Good luck. – Hastur Jul 17 '16 at 21:42
  • Can ping www.google.com which means has no Internet should be read as has a working connection to the Internet – Hennes Jul 18 '16 at 4:37
  • @Hastur Will have to convert the windows.exe to iso .... – Rhonda Jul 18 '16 at 18:17
  • 1
    Try to see (and update) what 1. the host (which is the system?), 2. the guest (xp) and 3. the second guest (kali) answer to host www.google.com (IP 173.194.122.242 or 2a00:1450:4010:c06::68) and www.cnn.com (151.101.12.73): one host that you reach and one that you cannot. Try to see when you put the IPV4 if you can see google for example. I'm starting to think there's a problem with IPV6/IPV4. Under windows you may use nslookup www.google.com when under Linux you use host www.google.com. – Hastur Jul 20 '16 at 8:18
  • 1
    Eventually you can install IPV6 under XP or to see for the specific problem under Virtualbox in NAT mode (I suppose). Let me know. Ps> I give that link to the iso just as example of the idea. You can search for other iso over the net.. – Hastur Jul 20 '16 at 8:23
1

5.Can ping www.google.com, but cannot browse to www.google.com

Are you able to connect to any other web sites? Normally, it suggests that there is something blocking the TCP 80 or TCP 443 connections.

First, please try to turn off the firewall on the host.

If it doesn't work, you may need to perform a network capture on the host to check if the host forwards the traffic for the guest correctly.

  • I tried www.facebook.com and no luck :-( – Rhonda Jul 18 '16 at 18:17
  • @Rhonda Have you tried to turn off the firewall on host?(Hypervisor) Also, you may try to capture the network traffic on the host by using tools like wireshark. – Steven Lee - MSFT Jul 19 '16 at 1:25
  • Yes, I tried turning off firewall. Will try wireshark network capture soon. – Rhonda Jul 19 '16 at 19:45
  • I turned off firewall with command 'netsh firewall set opmode mode=disable profile=all` I can access some websites and not others. I cannot access Google, Facebook, Hotmail. However I can access CNN, FoxNews, When I try to access nydailynews.com I get pop-up "Internet Explorer cannot open ... Operation Aborted" Please help! – Rhonda Jul 20 '16 at 1:00
  • 1
    If you are able to access some of these sites, it suggests that your client gets the internet. Please try to flush the DNS cache on the client with command ipconfig /flushdns. Then try to reset the browser. If it still doesn't work. You may need to perform a network capture on the client to check the detail process of the communication. From my point of view, there might be some firewall between your client and internet blocking some sites. – Steven Lee - MSFT Jul 20 '16 at 1:48
1

The same problem on:

Win8.1 host
Workstation 12
WinXP guest

I could ping 8.8.8.8, but could not open http://www.google.com in IE.

In this thread I found one line that solved the problem:

I just enabled TLS in the IE settings and the internet started working. I was able to ping websites but IE did not work. This helped me.

  • To enable TLS in Internet Explorer, go to Tools > Internet Options. In the Advanced tab, under Security, check Use TLS 1.0. – Zenadix Feb 2 '19 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.