0

I have searched alot and everywhere the issues are with the kali os ran through virtual machines. I have installed Kali linux latest version 2016.1 on my laptop. And its the single os on my laptop, still the wifi is not showing. I have checked ifconfig it shows only loopback and ethernet adapter and on iwconfig it says there are no such adapter. But my laptop has wirekess adapters. I am looking for the solution please help! I checked compat wireless, it only shows wlan0 but doesn't work.

  • Please add the output of lspci -knn | grep Net -A2 – GAD3R Jul 20 '16 at 18:09
1

I got the solution. We just have to upgrade our distro and kali now has provided the fix.

apt-get -yf install dist-upgrade now this will take some time and your problem will be fixed.

0

on iwconfig it says there are no such adapter.

It seems that the driver of your wireless adapter isn't loaded. Please look for the driver of your wireless adaptor on the official website of the manufacturer.

The kali Linux is based on Debian. So you may try to install the drivers for Debian. If it doesn't work, you may need to find the source code and compile & install it manually.

  • How to install those drivers? I tried but the problem wasn't solved. – Chirag Jul 19 '16 at 8:09
  • 1
    @Chirag The manufacture should provide the guide about how to compile and install it manually. If there is a binary package, just install it and load the module. Here is a good guide: wiki.debian.org/WiFi – Steven Lee - MSFT Jul 19 '16 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.