0

Possible Duplicate:
How to configure PuTTY so that Home/End/PgUp/PgDn work properly in bash?

I access a linux server shell via putty, but many of the keys I use do not translate across, up, down, left and right all are seen as ^[[A, ^[[B, ^[[D and ^[[C;
But so is C-up, C-down, C-left and C-right.
And enter is seen as C-j (which move down to the next line),
and backspace is seen as C-h, which is backwards delete.

How can I stop these keys being translated into other keys (so I can, for example, configure C-h and backspace to perform two different functions) and what's doing this translation (Putty, the kernel, the shell)?

$TERM is 'vt100', which I do have a terminfo file for. I'm actually using PuttyTel, which is like PuttyCyg (it connects to a cygwin process) but I had the same problems running just vanilla Putty.

Can nothing can be done from the server end (if the putty TERM setting isn't sending the desired codes in the first place) and which is the most conservative Putty (or even PuttyCyg/PuttyTel) TERM profile?

  • sounds like a duplicate of superuser.com/questions/94436/… ... does that answer your question? – quack quixote Feb 18 '10 at 0:32
  • It seems PuttyTel contains no setting in 'Connection > Data' for changing terminal type :-/ – Chris2048 Feb 18 '10 at 0:40
  • which version of PuttyTel are you using? the latest version is 0.60 and has the 'Connection > Data' in the configuration dialog. – quack quixote Feb 18 '10 at 0:44
  • re: server end. i discussed server-side configuration in my answer to the duplicate: superuser.com/questions/94436/… ... re: most conservative. i'm not sure what you mean. – quack quixote Feb 18 '10 at 0:46
  • if the duplicate link answers your basic questions, you're welcome to edit this post to add your additional questions. use the gray "edit" link on the question post (below the tags). – quack quixote Feb 18 '10 at 0:48