8

Is there no way to get decent, discernible audio over RDP? I'm just remoting from one machine to another on a Gb LAN and it's still so choppy I cannot watch a YouTube video. Why is this and is there a solution? Thanks.

6
  • Can you please share more details about your environment - what Windows versions you have on both client and server, all patches applied etc.?
    – cdavid
    Commented Jul 19, 2016 at 1:45
  • Yes, thanks David. I have Windows 8.1 Pro on the machine I'm remoting to and Windows 10 Pro (Surface 3) on the machine I'm physically using. Commented Jul 19, 2016 at 13:44
  • OK, One more question: As far as I remember, the Surface does not have a RJ45 port (network), so you have a USB adapter?
    – cdavid
    Commented Jul 19, 2016 at 17:26
  • 1
    I have been suffering the same issue. I tried the remote desktop from the windows 10 store (it's made by Microsoft) and the audio PLAYBACK worked perfectly, but I couldn't record from my current desktop. Hopefully we get resolution some time soon.
    – driz
    Commented May 4, 2017 at 20:52
  • 1
    I experience choppy video sound when RDP to Win2008R2 servers from Win10 workstation, but perfectly fine from Win2009Embedded thin clients.
    – ETL
    Commented Oct 8, 2019 at 21:36

2 Answers 2

5

Create an RDP configuration file (open mstsc, enter settings and use Save As).

Then open the .rdp file in a text editor. Add (or change if it's there) the setting:

audioqualitymode:i:2
3
  • 1
    @SamAndrew81, were you able to test this?
    – Leo
    Commented Feb 22, 2020 at 21:43
  • I tried it but it did not resolve the problem.
    – Tox
    Commented Mar 31, 2022 at 20:55
  • This seems to make it better: social.technet.microsoft.com/Forums/en-US/…
    – Tox
    Commented Mar 31, 2022 at 21:20
1

I know it's an old post but I've just had to find a fix for the same issue. I don't have enough reputation to comment so I have to post an answer.

Method 1 - Host defaults to Medium audio quality

On the host

  1. Open the Group Policy Editor
  • WIN + R
  • gpedit.msc
  • CTRL + SHIFT + ENTER
  1. Navigate to
  • Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection
  1. Edit policy: Limit audio playback quality
  • Click the 'enabled' checkbox

  • Select 'Medium' from the drop-down list

Method 2 - Host default is high quality but client requests medium quality

On the host

  1. Open the Group Policy Editor
  • WIN + R
  • gpedit.msc
  • CTRL + SHIFT + ENTER
  1. Navigate to
  • Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection
  1. Edit policy Limit audio playback quality
  • Click the enabled checkbox

  • Select High from the drop-down list

On the client

  1. Save an RDP file
  2. Open the .rdp file using Notepad (or other text editor)
  3. Add (or edit) line:
  • audioqualitymode:i:1

0 = Dynamic audio quality

1 = Compressed audio

2 = Uncompressed audio

In my experience audio has always been problematic with MS RDP so I'd rather just set the host to always output compressed audio and be done with it. Or use a 3rd party app like Rustdesk or Anydesk for RDP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .