1

There's new default Calculator app in Windows 10. Is there a way to get rid of calc.exe file from system32 folder? Reason: I don't want any built-in apps, but I have a habit of running calc command via Win+R. I removed Calculator with

Get-AppxPackage -allusers *windowscalc* | Remove-AppxPackage

but every time I run calc it reinstalls back. When I try to delete/rename the file, it says that it's write-protected, although it's not running (at least it's not listed in the task manager).

Alternatively, I also tried to create a file calc.bat in my folder and add it to PATH variable higher than other locations, so that my command would be found first, but for some reason this doesn't work, and Win+R > calc still installs&runs modern win10 calculator.

I'd appreciate any way to make calc command not run that app, but removal of calc.exe would be the best.

2
  • If you don't have the intention of running Calculator, why run calc.exe from Run.. can you pls clarify? Or do you have a 3rd party Calc replacement which you want to use?
    – w32sh
    Jul 19, 2016 at 13:41
  • @w32sh Right now, I just run it when I need to do numbers faster than I recall that I have win10, it's a habit. Also, I am not the only one who uses my PC, so I don't want to have to check whether metro app is back. Also, you are right and I will replace it with python shortcut once removed. Jul 19, 2016 at 13:46

3 Answers 3

2

Right-click Start, click Command Prompt (Admin)

Type:

copy rundll32.exe calc.com

That should prevent Calc from starting when you run calc from Run dialog. But you can still launch Calculator by typing calc.exe.

2
  • py.exe -> calc.com Jul 19, 2016 at 15:48
  • 1
    This doesn't actually solve the problem though, that original calc.exe is still there, and cannot be replaced with the old calc.exe because it cannot be deleted, renamed, etc. So which this answer is useful, it's not the solution to the original problem, which is what other people will be hoping to find an answer to when they search and find this post =( Nov 15, 2018 at 17:33
4

Most online instructions are incomplete, so the full set of steps required to actually delete the file are:

  1. Get-AppxPackage -allusers *windowscalc* | Remove-AppxPackage
  2. reboot

Which is mostly useless, but it's a start. To actually delete calc.exe from the system32 folder, you'll have to take ownership of it first, then delete it:

  1. Open the properties for the calc.exe file in the system32 folder, and go to the "security" tab, then click "Advanced".
  2. The only user account with full control will be the TrustedInstaller account, so select your own user account entry, click "edit", tick the "full control" box, and hit OK,
  3. Hit "apply" and verify your account is listed as having full control.
  4. Close the property dialogs and delete calc.exe

And then at this point you probably want to copy in Windows 7's calc.exe instead (a real one, not one you found online from a site you never downloaded anything from before).

4
  • Thank you! I'm finally forced onto Windows 10 by a company, but luckily they gave us local admin rights on the computer. Initially I set the owner to a group I thought I was in that still didn't allow me to delete calc.exe. After finding your answer and getting reassurance, I tried another group and it works. Firing up Windows 7 VM now to get the real calculator :)
    – drew010
    Jun 6, 2019 at 17:18
  • Make no mistake: if you weren't on Windows 10 already, you were guaranteed running on an exploitable OS. Install "Classic Shell" and "7+ taskbar tweaker", both free, and now your windows 10 is still windows 10, but feels like windows 7, and all is well. I fully endorse that company forcing you to switch to an actually maintained operating system. Jun 6, 2019 at 17:31
  • Yep already got Classic Shell (Open-Shell). I am/was running Linux (Mint 19 MATE). We are software developers, systems administrators, and security professionals so it was "all good" before?
    – drew010
    Jun 6, 2019 at 18:02
  • I will make no comments on your personal setup, that shouldn't be under your company's control. But if they needed you on windows on the job, at least it's windows 10, and not some earlier version? Jun 6, 2019 at 18:52
0

Cygwin (run as administrator) has no problems deleting calc.exe:

$ rm --verbose /cygdrive/c/Windows/System32/calc.exe
removed '/cygdrive/c/Windows/System32/calc.exe'

I did back it up with XCOPY first, just in case:

XCOPY C:\Windows\System32\calc.exe C:\Windows\System32\WindowsCalculator.calc.exe /K /X
$ ls -al /cygdrive/c/Windows/System32 | grep "calc\.exe"
-rwxr-x---+ 1 NT SERVICE+TrustedInstaller NT SERVICE+TrustedInstaller     27648 Mar 19  2019 WindowsCalculator.calc.exe

Note that calc.exe will be restored if you run SFC /SCANNOW:

[SR] Repairing corrupted file \??\C:\WINDOWS\System32\\calc.exe from store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .