0

Whenever I try to install VMware Workstation on my Windows 7 machine, "The feature you are trying to use is on a network resource that is unavailable." message pops up, requesting a "vmware_1424719112" directory with a tools-linux.msi

Why though? I have never installed VMware on this machine before. I had VirtualBox, but that is irrelevant. So how can a file downloaded from the servers be missing an msi?

I've found my own solution though not applicable for every situation for people reading this.

  • 1
    Same error as this? superuser.com/questions/460773/… – Hennes Jul 19 '16 at 17:30
  • The error message is the same, but the cause of the error completely different. I'm trying to install VMware, not some additional SDK. And this software has NEVER been on this computer. – Thomas Huber Jul 19 '16 at 17:33
  • What location is the VMWare installer extracting its resources? – Ramhound Jul 19 '16 at 17:34
  • @ThomasHuber - How do you know the cause is different? Have you ran the tool, from the answer to the possible duplicate, to verify it does not solve your problem? – Ramhound Jul 19 '16 at 17:35
  • I just did. And one issue has been resolved, though not related to VMware. Apparently I had another broken registry key. So thanks for the link. But back to topic. I've fixed the issue by downloading a tools-linux.tar from a link I found on Google. The question still remains why this issue occurs on a machine that's never been in contact with VMware before though. – Thomas Huber Jul 19 '16 at 17:39
0

I have solved the issue by manually downloading a tools-linux.tar from this directory and specifying it during the installation process.

Though not always applicable, for this scenario it worked.

-1

This is generally related to a registry entry of some sort, sometimes even detecting that the applicable software is already installed.

You might try https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed , or often I have even just searched the registry manually and deleted the keys - make sure you always back it up first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.