1

I recently upgraded to Office 2016 and I am trying to use an existing mail merge document. In the the past version, there was an option to allow blank lines to be printed when a merge field had no value in some pages. In Word 2016, the default seems to be to not print those fields and move everything up which is disrupting the layout. Where is that setting ?

2

Depending on the requirement above, in my instance I'm using an Excel spreadsheet as the data source in which it is possible to have missing data which ordinarily would shunt up remaining data, there is an option to print blank line when doing a mail merge.

  1. Use Customise ribbon option
  2. Select "All Commands" or "Commands Not in the ribbon" in drop down Choose commands from menu.
  3. Scroll down list and find "Mail Merge ..."
  4. Add new custom group (makes sense to add it to the Mailings Tab but could go anywhere)
  5. Add "Mail Merge ..." to the Ribbon list which will create a new Group containing the extra command.
  6. Selecting this command opens up a panel with a few options, one of which is the option of printing a blank line if no data is present.
| improve this answer | |
3

As far as I know, that setting hasn't been available from the standard user interface for several versions of Word.

You can still access it from the old "Mail Merge Helper...", which you can put in the Quick Access Toolbar (QAT), but I recommend that you do not use that Helper for anything else, because using it started causing one or two problems a few versions ago (though I cannot remember what exactly).

Or, if you are familiar with the VB Editor, you can execute a one-line piece of VBA code, e.g. in the Immediate Window:

ActiveDocument.MailMerge.SuppressBlankLines = False

To put the "Mail Merge Helper" dialog box in the QAT

  • use the Customize Quick Access Toolbar dropdown at the end of the QAT
  • select More Commands...
  • in the Choose Commands From dropdown, select All Commands
  • locate Mail Merge Helper in the list of commands and click Add to add it to the QAT
  • click the OK button.

To change the setting using the Mail Merge Helper,

  • create your mail merge main document and attach a data source to it in the usual way.
  • ensure the mail merge main document is the active document
  • click the Mail Merge Helper icon in the QAT
  • locate step 3 and click the Merge... button
  • click the Print blank lines when data fields are empty. button
  • I would then click the Close button, not the Merge button, and proceed with the Merge in the usual way. Again, ISTR that is the better choice in this case, although I cannot remember what might go wrong if you click Merge instead.)
| improve this answer | |
  • Wow that's a considerable loss of functionality. I went ahead and used the Mail Merge Helper and it seems to work fine for now at least. – chrisfs Jul 23 '16 at 9:33
  • I am upgrading from an older version to be sure, but to make a feature simply 'disappear' like that caused me considerable frustration until I figured out where it was. It's critical for some of the catalogs I print out in order to maintain a consistent length of each entry on the page. – chrisfs Jul 23 '16 at 17:37
0

Had a similar challenge with a document; found the following answer from Suzanne S. Barnhill which worked for me and could be helpful as alternative to other suggestions offered above.

"If you use line breaks (Shift+Enter) rather than paragraph breaks (Enter) at the ends of lines, then suppression of blank lines fails."

Answer excerpt from: https://answers.microsoft.com/en-us/office/forum/office_2007-word/mail-merge-to-print-blank-line-when-field-is-null/41ed24b8-4f81-43b3-b1e7-ac3ea314f604?auth=1

| improve this answer | |
0

The following is a low tech way that worked for me after spending over an hour trying other solutions to suppress blank lines with labels on Word 2016.

What I ended up doing was I walked through the wizard and generated the labels WITH the extra blank lines. I then saved the labels to a Word document.

You save to a new document by selecting "Edit individual labels" instead of "Print" (at the end of the wizard)

In the new document, do a "find/replace" to remove the blank lines.

In my case I use manual line breaks on labels (Shift + Enter).

So for the find and replace dialog box, I do it with shortcuts Ctrl + H (for find and replace)

Then for the find, look for ^l^l (that's a lower case L) and replace it with ^l.

This will take out any occurrences of a manual line break, followed by a line break on another line.

You will need to repeat this until there are no more instances of blank lines.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.