1

I have two routers set up for my home network. One is the primary router (which also serves as a modem). Running from a LAN port of this router is an ethernet connection to the WAN port of the other router which is serving as an access point in a bungalow out the back.

Both routers are Netgear DGN2200s, and the second router has been set using Access Point Mode (which I presume disables DHCP among other things). The manual suggests that connecting to the WAN port is necessary for this. The internet works fine in all cases.

The problem: If I have a laptop connected via WiFi on the primary router, and another connected via WiFi on the access point, sharing between them is problematic. i.e. Both are running Windows 10, but I cannot access shared folders between them - I will get a "Windows cannot access \\[other computer]" error when trying to access a shared folder. However they can share files fine if they are connected to the same router. Additionally, the sharing was also completely fine when I initially set up the routers - it only broke when I happened to restart the primary router.

Would greatly appreciate any help. I'm assuming this is likely to be a networking issue more than a Windows file sharing issue?

2

The access point setting would not disable dhcp and other settings. It just telling the router to set it's wireless module in a mode which can accept wireless connections from clients.
I also took a look of the manual for Netgear DGN2200 and I couldn't see the suggestion for LAN to WAN connection, so I think you got that a little bit wrong.
By connecting the WAN port for your access point router in the LAN of your primary router, you effectively put all the devices connected on the access point router in other network, behind nat from the primary router perspective point of view.
Here's how your setup should look:
Connect both router through their LAN ports and do not use WAN port. Go to the router which you want to use just for access point. Disable it's dhcp server. Make sure that this router have IP address assigned from the LAN network of your primary router. For that open the configuration of your primary router and goto Lan IP setup, there you should see something like:
Lan ip address: 192.168.0.1

IP subnet mask: 255.255.255.0

dhcp Starting IP Address: 192.168.0.2

dhcp Ending IP Address: 192.168.0.254

Change the starting ip address to 192.168.0.3 and set to access point router the ip: 192.168.0.2.
Then if you want to use single name for your wifi you should set it identical in both routers, among all other settings like security and etc. The only setting you should make sure is different is the channel.
The channels on the routers must be selected in such way that they do not overlap, see this diagram.
As you can see if you use channel 1 on the first router, on the access point router it should be at least channel 6. You should take to consideration the channels on which neighbor networks are broadcasting and try to avoid them if possible. For that task can help you tool like Vistumber.
I hope that helps.

  • Thanks for the reply! Was this the manual you looked at?: downloads.netgear.com/files/GDC/DGN2200V4/… - There's a heading on page 85 entitled "Wireless AP". I did try the manual route as you suggest to no avail, although I could try again in case I missed something. – Alex Z Jul 21 '16 at 9:39
  • No, but I will look this one. Anyway, try the method that I described in the answer. This is the solution in your case. – buzz boy Jul 21 '16 at 9:42
  • I tried to manually set it up as you suggested and it now appears to be working - for some reason it didn't work before, but did this time - thanks! – Alex Z Jul 22 '16 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.