46

I can't find a way to hide this "ENG" icon in Windows 10 (I could with 8.1). Is it even possible?

10 Answers 10

23

This method is for older versions of Windows 10 - See the below answer by Anders_K for new versions.

When I do it in my Virtual Machine it is the same method as my Windows 8.1 machine.

Control panel location: Control Panel\Clock, Language and Region\Language\Advanced settings > Options > Hidden [Check]

Update: If the above does not work - Try the path Control Panel\All Control Panel Items\Language and advanced options will be on the left.

enter image description here

  • 6
    Windows 10 doesn't seem to have that anymore. Did it move? -- Using 1803. – BrainSlugs83 Jul 30 '18 at 5:51
  • I still see it, the path may be Control Panel\All Control Panel Items\Language – Bitten Fleax Aug 1 '18 at 9:42
  • 4
    It seems also crucial (though counter-intuitive) that Use the desktop language bar when it's available is checked. – mpy Nov 21 '18 at 7:44
68

Search for

Turn system icons on or off

It should come right up.

MS you are so annoying...

  • 4
    This worked for me, all the other tips must be for some old version of windows or some other case... – Cyberwiz Nov 11 '18 at 14:17
  • Input indicator was off - I turned it on, it still isn't showing. – niico Nov 28 '18 at 7:44
  • 2
    this should be the answer, for newer devices – juntapao Jan 17 at 1:49
  • Works for me! Does MS revert this setting after doing a Windows update as they seem to do with the other fix that worked? – tbone Aug 18 at 1:25
20

I had a similar issue recently, this is what I did to get rid of the language bar & input indicator.

  1. open Start -> Settings -> Time & Language -> Additional date, time & regional settings -> Advanced Settings. There you have to uncheck Use the desktop language bar when it's available

enter image description here

  1. then go to Start -> Settings -> System -> Notifications & actions -> turn system icons on or off. There you have to switch Input Indicator to Off

enter image description here

  • 3
    Part 2 doesn't seem to be in the place described any more in the latest version of Windows 10, but entering "icon" into the search box finds the page shown. – U62 Aug 14 '17 at 9:44
  • 1
    Funny! I have to check "Use the desktop language bar when it's available" to make it go away. – Yaba Apr 23 '18 at 12:58
  • Input indicator was off - I turned it on, it still isn't showing.... – niico Nov 28 '18 at 7:45
9
+50

There seems to be 2 type of LANGUAGE icons in windows 10 at least, one is the one we were used to in Windows 7, and you could hide it right clicking it and changing the checkboxes.

In Windows 10 (I have Microsoft Windows v10.0.15063.502), this one

New W10 Icon

is hidden by entering Taskbar Settings, then under Notification Area select "Turn system icons on or off" , then switch "Input Indicator" off:

w10SysIcon.

The old one

Old Lang Icon

is hidden by going to "Control Panel\Language\Advanced settings", and under "switching input methods" select options at the right of the "Use desktop language bar when it's available" line and hide it from there, if you click "Change language bar hot keys" link on the left instead of the right Options link you will be shown with the same window but nothing here had any effect on my taskbar icon whatsoever:

OldWlangBarSttng

8

Neither of the above two answers worked for me, so I am adding this in case it helps someone in the future:

After having the language bar disabled and multiple input languages removed from my computer a long time ago, the "ENG" recently reappeared on my taskbar. I tried multiple methods of fixing it, but they were all already set to the correct values, which I had set long ago.

When I clicked on "ENG" I would get a list of two input languages, in my case "English (Canada)" and "English (United States)"

I only wanted English (Canada), and either way I don't want another icon on my taskbar. The confusing part was I couldn't figure out why it was there.

When I went to Control Panel -> Region & Languages, under Languages I only had English (Canada) listed. Like I said, all settings were already at the correct values. I don't know where the English (United States) was coming from.

What finally fixed the problem was in that same Languages page, there's a button "Add a language". So I did, I added English (United States). Then once it was added, I removed it.

Now the "ENG" bar is gone and everything seems to be back to normal. So if you're having problems, try just temporarily adding the language you don't want, and then removing it. Worked for me.

  • Thanks, this approach worked for me too. All the other suggested methods worked but only temporarily, as the language icon would always show up in the tray after some time, for no apparent reason. So adding and then immediately removing the languages (and keyboard configurations!) shown in the language icon's pop up menu got rid of the icon once again, but I suspect (fingers crossed) that this time it won't come back. – Oscar Hierro Dec 13 '17 at 23:57
  • Unfortunately, I can confirm that it does still come back, for me at least. Oddly enough it seems to go away when I reboot though. I have no idea. This is still the simpleest fix I've for getting rid of it temporarily though. I just wish it would be permanent... thanks Windows 10. sigh – cecilkorik Dec 14 '17 at 5:24
  • Yep, it did come back again after a while... :-/ – Oscar Hierro Dec 28 '17 at 13:06
  • I've heard elsewhere that the "English (United States)" keyboard is either something to do with the languages set up in Microsoft Office, or is added for compatibility with older programs. I'm not sure if that's correct though. – MoonRunestar Jan 24 '18 at 9:43
  • THANK YOU!!! I wonder how long this will last until Microsoft breaks it in another whack-a-mole update that users don't want. – tbone Oct 14 '18 at 21:26
5

This appears to be a bug in the latest version of Windows 10. To hide the language bar, you have to turn it ON, then go to Options and Hide it:

Control Panel || Clock, Language, and Region || Language || Advanced settings

(If you have the full Control Panel showing, click on Language || Advanced Settings)

Check "Use the language bar when available". Click Options. Select "Hidden".

This is counter-intuitive, I know, because if you UNCHECK "use the language bar when available", that makes it show on the task bar. That's why I think this is a bug.

You can also get to that screen by going to:

  1. Settings
  2. Time & Language (which is titled "Date and Time" at the top of the screen for some bizarre reason)
  3. Additional time, date, & regional settings (on the far right)
  4. Language
  5. Advanced Settings

ps. One of the annoying things about Windows 10 is Microsoft has created this new Settings screen but also left the Control Panel. Both of those screens are portals to nearly the same sets of settings, but in totally different paths and with totally different looks. This can be very confusing to new users.

  • Nice Answer ! Please keep sharing your knowledge, the site improves from contributions like yours ! – 123456789123456789123456789 Dec 22 '17 at 12:24
  • Only this answer worked here. Windows 10 update 1709 introduced several nasty bugs, and this is one of them. – RafaelLVX Feb 4 '18 at 21:30
0

Region & Language> Additional date, time & regional settings>Change Input Method

if you have the Canadian Language pack selected, add the US pack then move down the Canadian one and then you can remove that pack and the ENG will disappear! felt so go to see it vanish.

0

A lot of times the situation can be confused by the installation language of Windows. A lot of OEM installs are based on US English but installed on systems intended for other markets.

The OEMs use language pack installs to add regional settings for their intended markets and set the relevant defaults etc. but often don't bother to remove the unwanted/unnecessary language packs, so it is worthwhile checking that only one keyboard language is installed on a system before further investigation.

-1

Turning Off the "Input Indicator" from "Turn system icons on or off" seems to be the only working option, all other are useless and really seems to be a Bug of the latest upgrade.

  • 2
    How does this differ from the existing answer from June 2018? – Ramhound Feb 5 at 10:54
-2

imply right click the ENG in the notifications bar.

You will probably see more than one language eg British and US.

Remove the one(s) you don't want.

If there is only one left it won't show

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.