2

I bought a Tenda W311MI wireless USB Adapter for my desktop computer today and ran into the following problem from the very first use:

After installing the driver from the accompanying CD and plugging in the adapter my screen went wild, flickering with all colors of the rainbow.

I downloaded from the Tenda's website a newer version of the driver but it didn't help.

The event log doesn't contain any indications of the problem.

Obviously the driver somehow conflicts with the graphics driver, however I cannot verify that because of being unable to use the display when the device is plugged in.

I followed these instruction to be able to access some information about the driver while the device is not plugged in. However there is no simple clue on the surface.

How can I debug and fix this problem? Where should I start digging?

My desktop is a DELL Optiplex 9020 with Intel HD Graphics 4600 running Windows 7 Professional edition.

  • If you've sorted the issue, I'd recommend putting the fix into an answer of it's own (rather than integrating it into the question). The reasons are that it helps prevent clutter in the question, but also means that other people can see that this question is resolved (especially if you mark your answer as the correct one). Finally, if someone comes across this in the future because they're having the same issue, it'll make it clearer what the answer is, without having to read to the very bottom. – Matt Champion Jul 21 '16 at 13:02
  • @MattChampion Done – Leon Jul 21 '16 at 13:13
3

The problem was solved by plugging the adapter into a different USB port. Though the problem was present with two different USB ports (one in the front, the other one at the back), trying a third one made it work!

Though this answer doesn't provide useful information on debugging this kind of problems it suggests what you can try to have it solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.