6

Whenever I use imagemagick commands, I see errors and warnings like the following:

$ convert -size 99x99  caption:"t" -border 1x1 t.png
convert: clBuildProgram failed. (-11) @ warning/opencl.c/CompileOpenCLKernels/1097.
convert: clCreateCommandQueue failed. (0) @ warning/opencl.c/InitOpenCLEnvInternal/1424

I assume this is because of faulty or incomplete open source ati drivers on Linux.

How can I prevent Imagemagick from using OpenCL, without re-compiling it? I prefer to just use the version provided by my Linux distribution of choice - Arch Linux in this case.

7

It is possible to disable OpenCL support without recompiling ImageMagick. Setting the environment variable MAGICK_OCL_DEVICE to OFF will disable OpenCL. This will work for both ImageMagick 6 and 7.

| improve this answer | |
  • This does work, thanks! MAGICK_OCL_DEVICE=OFF convert -size 99x99 caption:"t" -border 1x1 t.png – qubodup Jul 23 '16 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.