I have a D-Link router. I want to connect to the settings menu (using in order to do things like port forwarding. I am unable to connect to this address while using Ethernet (Chrome just tries to load the page forever and nothing happens), but when connecting through WiFi I can load the page. Why might this be happening? I'm using Windows 10.

Update: Tried again with Edge and IE. Same result, page just hangs and doesn't load; I don't even get the sign-in prompt.

Update 2: Used the commands ipconfig /release, ipconfig /renew and ipconfig /flushdns. Page now doesn't load at all; Chrome just says

The page isn't working. didn't send any data. ERR_EMPTY_RESPONSE

Update 3: Doesn't even work with WiFi now. I changed nothing.

Update 4: After reading some stuff about Java and how Chrome no longer supports Java plugins (or something) I decided to try updating to the latest version of Java. Internet Explorer now says

This page can't be displayed

and Chrome says

The page isn't working. didn't send any data.

Update 5: Talked to a TalkTalk agent about the problem, no change unfortunately. My router is a D-Link DSL-3680

  • 1
    Are you connected to a wire LAN port and not the WAN port? (WAN port is the one usually facing the external network and hence the management interface is usually blocked from that port) – Hennes Jul 21 '16 at 23:44
  • @Hennes Yes I think so. I have an Ethernet cable plugged into the slot labelled LAN and the appropriate light is on – imulsion Jul 21 '16 at 23:45
  • Is the current IP of the computer in the 192.168.1.x range? – dxiv Jul 22 '16 at 0:57
  • @dxiv Yes. – imulsion Jul 22 '16 at 11:10
  • if it's now not working over either, I would restart the D-Link. After that, go in and check that you have enabled the management interface for the LAN interface, some routers you can specify which interface(s) the admin interface is available on. – Adrien Jul 25 '16 at 14:01

If you don't get anything back, and you've already tried resetting the router, then try booting a linux liveCD on the PC and accessing your router via browser on the linux environment over ethernet. If that works then we can assume the issues lies with your network configuration on the Windows 10 machine - something like a proxy setting, protocol setting, or driver is causing issues. Troubleshoot those manually or reset to factory defaults.

If linux can't access the router, we can assume the problem is hardware-based. Test as many of the following as possible:

  • Use a different ethernet port on the PC (might have to add a NIC if you have an old one laying around)
  • Use a different ethernet port on the router
  • Use a different ethernet cable
  • Try a different router
  • Try a shorter cable

This process should step you through the remaining possibilities. With every part of the chain tested, there is no possibility of the problem remaining after proper implementation of this process, unless you happen to be operating in an unusually high radiation or electromagnetic field.


Double check the IP address of the router (type Cmd from the start button and then type IPCONFIG)

It should be under "Ethernet Adapter Local Area Connection" (wired Connection) The default Gateway should read - The same as your "Wireless LAN Adapter Wireless Connection" setting. That is the address of the router.

If your wired connection reads Media Disconnected, Check or replace the cable.

  • We've been through this in the comments. I have the right address, my browser just won't load the page – imulsion Jul 25 '16 at 14:36
  • I don't have a D-link any more, but my old one had an ip of – Richard Hurley Jul 25 '16 at 14:38
  • This one is definitely – imulsion Jul 25 '16 at 14:39
  • 1
    I see you re-started the router, did you try the Re-set button to reset it to factory default? Wat is the model? – Richard Hurley Jul 25 '16 at 14:52

There are 3 possibilities for losing access to your router:

The most likely reason:

  1. You've accidentally set the IP obtained from Wi-Fi, as the only Management IP. So, if after ipconfig /release ipconfig /renew you obtained IP and you lost access to management service, then probably you can access it again by setting your IP manually to one of the addresses in the range - with the last one being the most likely address to solve your problem (last address before renewing your IP). Try to do that from Wi-Fi, since it was the last accessible workstation. If it doesn't help, a factory-reset is the only possible way IMO.

Just for your consideration, Not related to your problem since you had access to WEB panel using default port:

  1. You've disabled Management over HTTP for LAN zone. There's a chance that other management options like telnet are still accessible. Try to enable Telnet Client feature in your windows (if not already enabled) by going to appwiz.cpl> Turn windows features on or off> Telnet Client and open cmd then run telnet if it asks for username and password, then you are able to manage your router and even enable HTTP web panel.

  2. There's also a chance that you changed default port for Management services, it's HTTP:80 and Telnet:23 by default. If you changed both, then there's no way to recover access than remembering the port, or reset to factory defaults.

  • OK so I tried the things suggested in this answer. A 30-30-30 factory reset didn't fix the problem, the browser still says the page isn't working. I then tried point 2, enabling telnet. I ran the command and it exited with Could not open connection to the host on port 23: connect failed. Since it tried to connect on port 23 I guess point 3 isn't the reason either. – imulsion Jul 30 '16 at 17:02
  • Did your computer obtained an IP?? (make sure your network card is configured to obtain IP address automatically) If not, the router is probably broken. If yes, there's something wrong with management console of your router. In both cases, you should contact the manufacturer. – NetwOrchestration Jul 30 '16 at 21:38

I had a similar problem with my linksys router and even a factory reset wouldn't work. Weirdly, a factory reset followed by plugging the router into my network (LAN) but not plugging it in to the power outlet brought it back: 1.With the unit powered on, press and hold the reset button on back of unit for 30 seconds 2.Without releasing the reset button, unplug the unit and hold reset for another 30 seconds 3.Plug the unit into your computer with an ethernet cable STILL holding the reset button a final 30 seconds 4.Wait for a full minute before plugging your router back in.
Hope this helps.


1) Be completely sure you have only "one" DHCP server in your net; your Dlink router. (Wireshark traffic captures can give you an idea if your router is the ONLY DHCP service available and if it is assigning the right IPs or not)

2) Factory reset usually set Dlink routers management port to

3) Be sure yo do not have any MAC filter preventing WEB management.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.