0

Chrome 52 came our with messed up font rendering (I'm on Windows 7 64). Someone recommended to install Chrome Canary to check if the font issue is still there. After installing Canary, it couldn't connect to Internet. Here's the best part: it also damaged the regular Chrome. Now I can't connect to Internet in Chrome due to this error:

This site can’t be reached

example.com’s server DNS address could not be found. DNS_PROBE_FINISHED_NXDOMAIN

Every other browser works well, so it's a Chrome issue. In Chrome, I can access sites only via IPs. I tried every possible solution I found: restarting my router, changing my dns server to opendns, clearing dns cache or renewing dns (both in Chrome and Windows), checking or removing the Windows\System32\drivers\etc files, rebooting my computer of course, the Chrome incognito mode, changing HKEY_CURRENT_USER\Software\Google\Chrome\BLBeacon\status from 1 to 0, removing antivirus, reinstalling Chrome. Nothing helps.

UPDATE:

I uninstalled Avast Antivirus. When I try to install it back, it gets stuck at the very beginning with no information. Maybe Canary messed up the dns matter beyond Chrome.

0

I managed to get rid of this issue like this:

  1. I uninstalled Chrome (52) again.
  2. Installed Chrome Canary (54), uninstalled Chrome Canary, installed Chrome (52) - no success.
  3. Uninstalled Chrome (52), Installed Chrome Beta (52) - no success.
  4. Uninstalled Chrome Beta, installed Chrome Dev (53) - success.

It works now, so I will stay on the Dev version of Chrome. The Avast issue seems to be unrelated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.