I want something similar to Chrome Incognito Tab where all addons and extensions are disabled by default. Unfortunately, entering private mode in Firefox doesn't do that and extensions still have access to web page content. I want to avoid it while browsing through my bank account.


Private mode doesn't disable extensions

As pointed out in chat by rahuldottech, Firefox 67.0 has made some changes to extensions and private browsing:

enter image description here

Extensions in private windows

In previous Firefox versions, any extensions you installed would run in private and non-private browsing windows by default. This could be problematic if an extension accessed information you would rather keep private while browsing in a private window.

Starting in Firefox version 67, you will be able to decide which extensions will run while you are in private browsing. Additionally, an extension will no longer automatically be able to work in private browsing; you must grant it permission, either when you install the extension or later, through the extension’s settings.

If you do not give an extension permission to work in private browsing, it should still work normally in non-private browsing, unless the extension explicitly uses features that require private browsing access (like opening new tabs in a private window).

Granting permission on installation

When you install a new extension, you will see a prompt asking if you would like this extension to work in private windows.

If you would like the extension to work in private browsing, click on the box next to Allow this extension to run in Private Windows to add a check mark and then click on the Okay, Got It bar.

enter image description here

If you do not want the extension to have access to your data in private browsing windows, leave the box unchecked.

Enabling or disabling extensions in private windows

  • Click the menu button, click Add-ons and select Extensions.
  • Click on the card of the extension you would like to manage.

    This will open a panel where you can manage extension settings.

    enter image description here

Underneath the description of the extension, you will see extension settings. Next to Run in Private Windows, select Allow to enable the extension to work in private browsing or select Don’t Allow to disable it in private browsing. Once you have made your selection, you can exit the Add-ons Manager.

Source Extensions in Private Browsing

Older Versions

You can start Firefox as follows:

firefox -private -safe-mode


Opens Firefox in permanent private browsing mode. Firefox 3.6 and later only.


Launches the application with all extensions disabled, for that launch only. (Extensions are not loaded, but are not permanently disabled in the Extension Manager data source).

Source Command Line Options

Safe Mode

Safe Mode is a debugging startup mode available in Firefox, Thunderbird, and SeaMonkey 2, where all added extensions are disabled, the default theme is used, and default localstore settings (toolbar settings and controls) are used.

Safe Mode also disables hardware acceleration, the Just-in-time (JIT) JavaScript compiler, and any changes made via userContent.css and userChrome.css. Any changes made to preference settings remain in effect in Safe Mode, however, and all available plugins are used. To summarize:

Safe Mode temporarily affects the following:

  • All extensions are disabled.
  • The default theme is used, without a persona.
  • The Just-in-time (JIT) JavaScript compiler is disabled.
  • The userChrome.css and userContent.css files are ignored.
  • The default toolbar layout is used.
  • Hardware acceleration is disabled.

Safe Mode has no effect on the following:

  • The status of plugins is not affected.
  • Custom preferences are not affected


For Firefox, one of these:

firefox -safe-mode
"C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode
"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode

Source Safe Mode

enter image description here

| improve this answer | |
  • I've tried it before and the problem is: I click Windows+R to open "Run" window, I type "firefox -safe-mode" and what I get is classic firefox with all extensions enabled. – Piotrek Jul 22 '16 at 22:00
  • @Ludwik11 It works for me. Proof: i.imgur.com/N7AQP68.png – DavidPostill Jul 22 '16 at 22:12
  • @Piotrek Answer update for Firefox 67 – DavidPostill May 26 '19 at 19:35
  1. Create a new profile
  2. Name it "private" or something similar

Now start firefox with the new profile and the appropriate flags:

firefox --new-instance --private-window --safe-mode -P private

The reason you need to create a new profile is that otherwise when you open the window when you're already running firefox it will ignore the --safe-mode since it'll use the existing firefox setup

| improve this answer | |
  • The trick with the profile doesn't work for me anymore. It just ignores the profile parameter. Does it still work for you? – fabwu Oct 6 '18 at 9:55
  • Yes, it still work for me. – Dror Oct 7 '18 at 16:38
  • On my machine it only works if I close Firefox and start the private instance first. Are you able to start a new private instance if Firefox is already open? – fabwu Oct 8 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.