1

I have a partition for Linux Mint Cinnamon 17.3 rosa installed and I decided to install Gnome 3. I decided 5 minutes into it that I did not like it, so I removed it using the command

sudo apt-get remove gnome-session

after running that command, I ignorantly figured I was finished and rebooted. Now it displays the mint logo and stays there, then eventually displays "Keys: Continue to wait, or press S to skip mounting or M for manual recovery" at the top left, but none of these keys do anything.

I've tried booting into recovery holding shift which does nothing, most likely since it is a partition. none of the function keys do anything aside from toggling the boot screen to appear and disappear, and when I try to do ctrl-alt-f2/f3, it opens up a console and logs into my user but displays many of this type of error code

[ xxx.xxxxxx] pcieport 0000:00:1c.7: PCI e Bus Error: severity = Corrected, type=Pysical Layer, id=00e7(Receiver ID)
[ xxx.xxxxxx] pcieport 0000:00:1c.7:   device [8086:a117] error status/mask=00000001/00002000
[ xxx.xxxxxx] pcieport 0000:00:1c.7:    [ 0] Receiver Error

Aside from this, I don't know what else to try. There's no way I've found to get access to a terminal, grub, or boot into recovery.

2

Despite those errors coming through on the console you should be able to issue commands via a vterm (ctrl+f2-7) if you just hit enter or ctrl+l (that's a lowercase L, for clarity) you should get a bash prompt.

You could certainly try reinstalling gnome-session via that shell, just to see if that resolves the issue.. However, I hate to say it, but seeing device errors such as that is not a good sign, and often times is a sign of drive failure.

You might first try forcing a check of the filesystem at your next boot by issuing the following commands.

You'll need to be root, so

sudo -s

then create a file at the root of the filesystem called "forcefsck"

touch /forcefsck

then reboot and the OS should enforce a filesystem check at next boot.

reboot

If the check doesn't report any errors, then hooray! we can worry about restoring your OS.

Regardless, there should definitely be a way to restore your data. This might feel scary, but if the drive isn't completely fragged, then we should have no problem recovering your data.

  • Awesome! I was able to login from the console without being berated by those error messages. Once I got terminal access, I ran the command sudo apt-get install mdm since gnome uninstalls the mint login screen and replaces it with its own gdm. Anyways, I have it up and running now, thank you :) – Neuromeda Jul 23 '16 at 1:08
  • Great news!! I'm glad to hear that everything works again :) – p_q Jul 23 '16 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.