This question already has an answer here:

Just switched to Win 10 from Win 8.1. A program is giving an error at startup (C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.tlb could not be loaded) so I tried to reinstall .NET Framework.

I've tried with all the possibilities I've found and even installing some components that indirectly install it but alway it ends with:

.NET Framework 3.5 (includes .NET 2.0 and 3.0)

The system cannot find the file specified. Error code 0x80070002

I've spent a lot of time searching possibilities, let's see if anyone has a clue or an undesired revert to Win8.1 is on the horizon...

UPDATE: From the suggestion in a comment by @magicandre1981: Can't install .net 3.5 on Windows 10

Pointing to: https://blogs.technet.microsoft.com/mniehaus/2015/08/31/adding-features-including-net-3-5-to-windows-10/

I executed:

DISM.EXE /Online /Add-Capability /CapabilityName:NetFx3~~~~ 

And it worked! 100% completed without problems. Now almost all is fixed except when I try to open a Properties window on Visual Studio 2008 (the main user of the .NET 3 it says

Failed to create .NET Frameworks PropertyGrid component. Please verify that the Common Language Runtime and .NET Frameworks are properly installed.

Haven't dug deeper but I hope to fix this -hopefully- last one.

marked as duplicate by magicandre1981 windows-10 Jan 10 '17 at 16:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Exactly how have you tried to install it? Is this computer on a domain that utilizes WSUS by chance? – Ƭᴇcʜιᴇ007 Jul 23 '16 at 16:01
  • Not sure of what is WSUS so if it's something that you have to install not. It's just an upgrade from Win8.1 toWin10 (online under the free offer from MS), System on a small local network but with no especial setups. I've tried to locate the logs of the install to find some clue of what is the missing file but this thing is elusive. I've lost account of what I've tried but always end in the installation of .NET 3.5 that ends with the error. – Joan Jul 23 '16 at 17:49
  • @magicandre1981 It doesn't refer to the same error number but from there I got a substantial advance (see the Update in the post). Thanks – Joan Jul 23 '16 at 19:11
  • run such an old VS version in a Win7 Virtual Maschine . the error seams to come from the 3.5 SDK – magicandre1981 Jul 24 '16 at 6:15

If you have windows 10 installation media (DVD, ISO, USB) attach it. Run cmd as admin and run:

dism /online /Enable-Feature /FeatureName:Netfx3 /All /LimitAccess /Source:E:\sources\sxs

Where E:\ is the drive letter assigned to installation media. If you still get error, you have to uninstall every update to NetFx4.5, then repeat steps above, and again update NetFx4.5 as stated here. Also check out here if you're joined to domain.

  • As the upgrade was online I had no DVD but see the Update in the post as this was a good route. – Joan Jul 23 '16 at 19:13
  • Did you tried /Enable-Feature with /All switch? it installs all dependencies and parent components related. – NetwOrchestration Jul 23 '16 at 19:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.