0

I have dell (alienware) laptop connected to dells 3.0 usb docking station. This was working fine until I was playing a game (ARMA 3) and Windows 10 crashed with a memory dump error. Something tried to write to an incorrect memory location. If I thought it was something more then a reboot I would have payed more attention to it.

I extended my laptop screen to one of the connected monitors to play my game. I have not done this before but I wanted to try playing on a bigger monitor. Previously I only ever played games directly on the laptop. After 15 minutes or so everything crashed and windows performed a memory dump (first time in a long time this has occured for me in a very long time).

To solve the issue I rebooted but none of the monitors connected to the usb docking station were recognized (display settings). The odd part was that everything else connected to the usb dock was working as normal but the monitors were not. One is connected via hdmi and one is connected via the DP style connection. I then tried to connect the hdmi directly to the laptop and that worked. I have not dp connection on the laptop.

The next step was I reinstalled the video drivers for both the intel and nvidia cards. Following that I tried to uninstall and reinstall the usb display adapters from the device manager. I also tried various combinations of rebooting and restarting with the dock plugged in. I left the hub unplugged for 10 hours to see if it was chip with a capacitory holding a bad charge.

Hardware: Windows 10 Pro laptop Dell d3100 USB3.0 Dock
How to go about getting the monitors recognized ?

0

It sounds like the DisplayLink USB device (display processor) in your dock station has died. Did you try this usual USBView utility

link

to see if the DisplayLink processor is in the USB tree and has no yellow marks? Make sure that the entire docking station operates at USB3 speed. Most reliable way is to use this USB dongle and determine the speed of USB link between laptop and dock:

link

Also, try to borrow another good D3100 to see if your drivers are OK, or try another computer with good known USB3 port to see if the problem goes with your questionable D3100, or your computer. It could be that your computer has developed a problem with xHCI (USB3 controller) and operates only in USB2 mode.

1
  • I was able to get help from dell and it turned out to be two things a bios update was needed but also more importantly the drivers on dells website for the D3100 were out of date. The call center provided me with updated versions and that solved the problem. – Dan Aug 4 '16 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.