1

I have an SSD and bought external enclosure USB 3.0 for it, but when I insert it in my Dell laptop (windows 10 os) it does not appear on my computer window although it was working fine with an older USB 2 enclosure. When I ran Disk Management it appears as 'Disk 2, Removable E:, No Media' and on Device Manager there seems to be no problem showing. I tried to open it on other laptop (windows 7 os) and desktops (windows 7 and 10 os) it works fine on that machines with this new enclosure. Also I have tried to change drive letter in disk management and to update drive by search online but it doesn't work as well.

Thank you

6
  • Do you have a USB 3 port? – Ramhound Jul 24 '16 at 21:14
  • Format the drive with NTFS type File System. – Raktim Biswas Jul 24 '16 at 22:24
  • What type of enclosure is it? May need to break out that manual. – Musselman Jul 25 '16 at 3:01
  • My enclosure is one like this amazon.co.uk/gp/product/B00TGU0NOS/… – Ghaith Jul 26 '16 at 12:16
  • Yes all my laptop ports are USB 3.0 – Ghaith Jul 26 '16 at 12:17
0

It seems the SSD is beginning to develop some fault, in order to be able to get your data, please perform a SSD recovery and then format to see if issue is resolved. You can check the link below for guidelines http://www.latestsolution.com/2016/06/how-to-recover-files.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.