2

I'm trying Krita for the first time (version 3.0), following this Bob Ross tutorial with some custom brushes: https://www.youtube.com/watch?v=aw9LwWcNSgY

Krita is very laggy and slow - such that I can't draw properly.

Is there anything I can do to fix this?

I found this topic: https://forum.kde.org/viewtopic.php?f=281&t=125170 but can't logon to post because the KDE forum is unusable - tells me "Error 403 Client rejected by automatic spammer detection system"

My pc is Windows 10, 16GB RAM, i5 3Gz.

My image is 18" x 20", 300 dpi. At 100 dpi it's slighty better, but the mouse still keeps jumping around unpredictably after I've moved it.

  • Hi @Richard, welcome to GDSE. We're not really tech people here, being desingers, so I'm not 100% sure we're going to be able to help you. The forum you linked to doesn't provide much help, except maybe try to disable OpenGL. – PieBie Jul 23 '16 at 21:29
  • Oh wow. That actually makes a big improvement, thanks. For other people wanting to know how: Settings - Configure - Display - Uncheck OpenGl – Richard Jul 24 '16 at 7:37
  • I added our comments as an answer. If you could please accept it, so the system can mark this question as done (unanswered questions keep getting bumped to the top of the front page you see) and I'll get some rep for helping you. – PieBie Jul 24 '16 at 8:44
  • 1
    @Richard I'm new to Krita myself, though I notice that disabling Instant Preview Mode can reduce some lag with some brush strokes. You can disable it by unticking the option under View>Instant Preview Mode. I think this mode exists for working on very large illustrations though it may be better to disable it depending on what sort of brushes you're using. – johnp Jul 24 '16 at 21:58
6

According to the conversation you linked to, disabling OpenGL can cause significant speed improvements in some systems.

Go to Settings > Configure > Display > Uncheck OpenGl

  • That did indeed provide an immediate decrease in lag for me (Windows 7, Krita 2.9.9). Thanks! – Ron Burk Nov 8 '16 at 17:12
  • Although, upgrading to 3.0 got rid of the lag without having to disable OpenGL. :-) – Ron Burk Nov 8 '16 at 17:21
  • I can confirm that disabling OpenGL fixed the sluggishness on Krita 3.3.3 64-bit on Windows 10. – Ates Goral Jan 22 '18 at 15:20
1

Im my case, Krita was responding very poorly until I unchecked OpenGL, as PieBie also mentions in his answer; once unchecked, however, I was able to move the screen around but the brushes weren't registering when I tried to draw. So I fiddled around and found another setting that was decisive for me:

increase the memory limit under Settings > Configure Krita > Performance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.