1

I saw multiple threads regarding this issue, and no solution has worked out for me. <Can't install Java\JDK on Windows 10>, <JDK 8 installation does not progress on Windows 10>

I have downloaded the official Oracle exe windows installer for 64 bit system, and tried to install it. After the initial extraction is complete, the "status" progress bar freezes and I can't find any solution:

  1. I run it as administrator.
  2. I activated the hidden windows 10 admin account, and ran it as administrator once again.
  3. I disactivated the UAC in windows control panel.
  4. I formatted my windows 10 OS completely.

I really ran out of options, and this is the most frustrating thing ever. Please help me.

Here is OK:

enter image description here

Here is the FREEZE progress bar:

enter image description here

Few Notes:

  • I didn't have these issues with any other software I tried to install

  • I installed successfully the java-7 latest public release.

  • Your hard drive isn't full, is it? – JaredT Jul 25 '16 at 18:26
  • Not at all. It is almost empty for the matter of fact, the OS was completely formatted. – Mike Jul 25 '16 at 18:34
  • Hmm.. have you tried installing in safe mode? – JaredT Jul 25 '16 at 18:40
  • @jatuttle0 thank you very much, I didn't try it and it worked. Also I noticed, that the jdk was actually installed, and the extra step that was stucked was just the "close" button with "success" message. – Mike Jul 25 '16 at 19:59
  • @Mike: You can answer your own questions and accept it as the answer that worked, or make up for @ jatuttle0, this gives the site a working answer for this question should anybody have the same problem, you can also add more detail to the question giving a broader base for searches of similar questions, thankyou – mic84 Jul 27 '16 at 0:52
1

As @jatuttle0 suggested, installing the jdk from safe mode did the trick. Also, I think that if all the files were extracted to C:/Java/jdk... then you shouldn't be worried too much for this freezing progress bar since it doesn't do anything accept saying that the installation was successfull.

0

First install the JRE before installing the SDK.

-1

Try this, it's works for me.

  1. Run Command Prompt as Administrator.
  2. Then, run the JDK installation file (.exe) in Command Prompt

Gook Luck!

  • Welcome to superuser: not everybody would understand now to install or run the file from cmd. Could you expand your answer as this answer has been accepted and this is a 'you could also try it this way'. You may have already read help center or How to Answer so anyway again welcome to superuser. – mic84 Jul 6 '18 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.