0

The icons on my desktop are invisible, however, when I press F5 they show correctly for about 0.1 seconds before disappearing again.

When I run the following batch script downloaded from How to Rebuild the Icon Cache in Windows...

@echo off
set iconcache=%localappdata%\IconCache.db

echo The Explorer process must be killed to delete the Icon DB. 
echo.
echo Please SAVE ALL OPEN WORK before continuing.
echo.
pause
echo.
If exist "%iconcache%" goto delID
echo.
echo Icon DB has already been deleted. 
echo.
pause
exit /B

:delID
echo Attempting to delete Icon DB...
echo.
ie4uinit.exe -ClearIconCache
taskkill /IM explorer.exe /F 
del "%iconcache%" /A
del "%localappdata%\Microsoft\Windows\Explorer\iconcache*" /A 
echo.
echo Icon DB has been successfully deleted. Please "restart your PC" now to rebuild your icon cache.
echo.
start explorer.exe
pause
exit /B

Everything works great until my computer is rebooted.

The icons in file explorer (when I browse the files on my computer) display correctly and seem completely unaffected at all times. So, of course, the issue is only with my desktop icons.

I also followed the How to increase Icon Cache size in Windows 10/8/7 tutorial but nothing seems to have changed (even after rebooting).

How do I permanently fix this annoying problem?

  • You could run the above batch file on startup ... – DavidPostill Jul 25 '16 at 17:53
  • lol I thought of that exact same bodge job already... Not the solution I'm looking for though. – charlie Jul 25 '16 at 19:40
  • 1
    If you log in as a different user, do they behave the same way? "Everything works great until my computer is rebooted." If you (re)boot back up in Safe Mode instead, do they stay "fixed"? – Ƭᴇcʜιᴇ007 Jul 25 '16 at 19:58
0

Edit the above batchfile to include the following line after taskkill line:

timeout/t 5 > nul:

This inserts a 5-second delay, allowing enough time for the batchfile to kill all Windows Explorer processes before cache file deletions commence. (I know this from having just tested and modified a similar batchfile on my system.) Now run the batchfile and restart your computer.

Before running it every time, you should close all open programs, as many programs open the icon cache files, which prevents the batchfile from working properly.

To check it did work properly, after rebooting check out the following files: IconCache.db in %localappdata% , and all files with names starting with iconcache in %localappdata%\Microsoft\Windows\Explorer . All creation dates/times for these files should be on/after the date/time you ran the batchfile. If not, it failed.

If it failed, try booting to Safe Mode and running it.

Still have the problem? There can be reasons other than a bad iconcache causing icons to disappear from your desktop. This topic is worth a look. Certain installed third party programs with certain settings can prevent desktop icons displaying (e.g. Iconoid, by design) or cause Windows' Show desktop icons setting to be turned off (e.g. Infrarecorder). Good luck!

ADDENDUM: Actually you won't see any iconcache files in %localappdata%\Microsoft\Windows\Explorer, since they are only present in Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.