1

The subject computer is setup to dual boot Win 8.1 and Ubuntu 14.04 with no problems. I'm trying to prep for an upgrade to Ubuntu 16.04 but I can't get it to boot off USB!

I remember struggling with that back when I installed Ubuntu in 2014 but this is different. That time, I learned that I had to set the USB as the first boot option in UEFI in the same boot session and it would work (i.e. the boot order was not preserved).

This time, I can get it to recognize the USB by changing the boot order in the UEFI, but when it tries to boot, I get a Secure Boot Error and it returns to the UEFI interface. When I tried to turn off Secure Boot, the system always boots to Windows...which is baffling.

I wonder if maybe I am not turning off Secure Boot properly? I went to this screen in the UEFI and on the button that says Windows UE..., I changed it to "Other OS" (the only other option). But after this, it boots straight to Windows.

enter image description here

One difference from 2014 is that Ubuntu pushed out a recent change that required me to turn off Secure Boot using mokutil...I thought...but it seems that it isn't really turned off?

My USB is recognized as UEFI so that isn't the issue.

There is no use booting it in legacy/CSM mode because the Windows install is in UEFI mode. So I need to install the Ubuntu 16.04 in UEFI mode.

This Asus UEFI interface is really baffling. I'd appreciate any guidance on how to get this machine to boot from USB.

1

As usual, posting a question provided the spur to figure out the answer for myself. Posting the answer just in case any other Asus users come here.

It turns out this is a two pass process, which is what had me stumped.

First Pass (disable Secure Boot)

  1. Do not plug in the USB yet.
  2. Restart the PC. Hold F2 for UEFI.
  3. In the UEFI hit F7 or select Advanced Mode.
  4. Select the Boot Menu.
  5. Select Secure Boot.
  6. Change the OS Type from Windows UE... to Other (the only other choice).
  7. Exit, saving changes, and allow the boot to proceed. It will boot to Windows.

Second Pass (boot to USB)

  1. Plug in the USB.

  2. Select Restart from Windows power menu. Hold F2 for UEFI.

  3. On the initial UEFI screen, drag the USB to the leftmost position. Drag the 2 Ubuntu entries to the left. (Ensure Windows is last).

  4. Exit the UEFI. It will say you didn't make any changes, but it will boot to the USB.

| improve this answer | |
  • Did that but at 7. (after setting "Other") it doesn't boot to Windows anymore. – e2-e4 Oct 25 '17 at 14:33
  • I now grub-boot the thing from an .iso stored on a separate hard drive. This process was just too ridiculous. – Organic Marble Oct 25 '17 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.