1

I have this Logitech G105 Keyboard and I would like to disable Dead Keys, and still keep the Keyboard's Layout.

I am using English (US, alternative international) since it matches my keyboard buttons.

The problem is that no matter what Layout I choose, I still have Dead Keys enabled.

  • Welcome to SuperUser! You will probably get better expertise on AskUbuntu. – fosslinux Jul 27 '16 at 1:01
  • I tried there, no actual answer. Only "use a keyboard layout without dead keys" – TermoZour Aug 5 '16 at 10:16
0

There are two keysyms for grave, grave and dead_grave, by default dead_grave is set to the ` key. xmodmap can be used to change it, and should be in Ubuntu by default (with arch install xorg-xmodmap).

To change it from the default dead_grave to grave, run:

xmodmap -e "keycode  49 = grave notsign grave notsign brokenbar notsign brokenbar notsign"

The rest of the values are various modifiers, e.g. the second one is shift.

If you want this to be permanent, create ~/.Xmodmap, and then add just:

keycode  49 = grave notsign grave notsign brokenbar notsign brokenbar notsign

If there are any other dead keys you're having trouble with, run:

xmodmap -pke | grep dead

And it should give you a list of dead keys. Alternatively you could run:

xmodmap -pke >> ~/.Xmodmap

You will then have a full list of keyboard keys and their sym values in .Xmodmap, which makes it easy to change your dead keys and any other keys to whatever custom layout you like.

| improve this answer | |
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill May 14 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.