61

Situation:

I have a MacBook pro MacBook Pro (Retina, 15-inch, Mid 2014)

And have 2 External Monitors ASUS VS247 Display connected via thunderbolt.

On each monitor, I have multiple Desktops/Spaces open.

Problem:

When I wake my mac from sleep, sometimes, it switches the recognition of the monitors and all the Desktops/Spaces from Monitor2 are now on Monitor3 and all Desktops/Spaces from Monitor3 are on Monitor2.

The main monitor (the one on the laptop) always stays the same.

This happens on an average once every month. I was unable to find a specific cause for this to happen.

I have my thunderbolt cables and ports color-coded. So, I am definitely not switching the cables around.

More info:

This is how my mission control settings look like.

[NO] Automatically rearrange spaces based on most recent use?
[Yes] When switching to an application, switch to a Space with open windows for the application.
[No] Group windows by application.
[Yes] Displays have separate Spaces.

Does anyone else have the same issue? If so is there a fix?

  • 6
    Every time I connect my external monitors, its a crapshoot. As often as not, the displays are flipflopped. – George Cummins May 8 '17 at 14:17
  • 3
  • 2
    @geva This is not the same issue as desktops getting rearranged by recent usage. – Sai Phaninder Reddy J Jun 12 '17 at 18:04
  • Same problem today, with a MacBook Pro (15-inch, 2019). Two monitors, HDMI with adapter for USB-C. It happens at every plug/unplug if they are separated by minutes. @Josh answer applied, time will tell... – Rémi Belzanti Aug 9 at 12:18
  • Well it's been 3 days and the problem is still there. Thus I must say the problem is also present after I lock the screen and unlock it minutes later... This means no physical plug/unplug operations, yet I'm in trouble :( – Rémi Belzanti Aug 13 at 13:18
35

Yes! I have 4 external monitors and this drove me nuts until I figured it out. Play around with moving the "top" bar between screens in the Arrangement window. Assign it to different screens and you will notice it will solve your issue once you find the "right" screen. I can't remember why that worked, but it did.

How to move the top bar between Mac windows

  • 4
    Screenshots here: apple.stackexchange.com/a/296905/206646 – ognockocaten Aug 30 '17 at 19:24
  • Just had this happen to me again (hasn't happened for a while so I forgot the solution) and this post came back up. Thank you... again! – davestewart Sep 15 '17 at 9:13
  • 2
    That's great. I had to re read my own post too recently! – Josh Sep 17 '17 at 14:56
  • 3
    This doesn't work for me. :( – ForeverWintr Aug 9 '18 at 5:54
  • 1
    This is also just a temporary solution that needs to be done every time this problem happens. This also happens for me when the laptop wakes up from sleep mode (with all the screens still plugged in) – Vidak Jul 22 at 12:24
11

For me it's based on which cable I plug in first, even when I plug them into the same ports. I'm using two HDMI cables. If my screens end up swapped, I just unplug one of the cables and plug it back in. If the screens are still swapped, I unplug the other one and plug it back in. The screens will both flicker and they'll swap back to normal.

This seems like an OS bug, but I have no way of knowing for sure.

  • 3
    we use CalDigit TB3 docks and have this issue, intermittently – race_carr Mar 8 at 17:42
  • I'm using HDMI cables plugged directly into the laptop via USB-C converters. – Dan Aug 29 at 19:14
5

I "solved" this problem using https://github.com/jakehilborn/displayplacer. If I connect my hub and the monitors are incorrect, instead of having to rotate screens or reconnect cables, I can now run a script (via a hotkey) to resolve this.

First, make sure your monitors are in the correct configuration. Then install displayplacer and run it.

brew tap jakehilborn/jakehilborn && brew install displayplacer
displayplacer list

At the bottom of the output you'll see that it generates the command which will place your monitors in the back into the current configuration. Example:

displayplacer "id:C00DE6B5-2BF1-D707-8452-14BD6BFAAC84 res:1920x1080 hz:60 color_depth:8 scaling:off origin:(0,0) degree:0" "id:D0823E00-B252-0F5C-DE87-D142F95D0CB4 res:1680x1050 color_depth:8 scaling:on origin:(-1680,0) degree:0" "id:1A13BBCA-7176-912E-4048-7E7E22D786C2 res:1080x1920 hz:60 color_depth:8 scaling:off origin:(1920,-386) degree:90"

I then created a service/action and set a keyboard shortcut for this item. Now a quick keystroke will resolve the issue.

More info: The answer by Dan is the root of this problem for me. I have two identical monitors, both being connected to a hub via Displayport. That hub is connected to my mac via one USB-C connection. Randomly, the dock will load the settings in a different order which causes this issue. Since my 3rd monitor is rotated, this makes two screens now improperly rotated.

For months I have been disconnecting both DisplayPort connections on the hub, and then reconnecting in the reverse order. This solves the problem, but it was really annoying.

  • 1
    this worked like a charm for me. upvoted! – Micah Stubbs Aug 21 at 21:17
  • Thanks for this! – Gary Reckard Aug 31 at 3:40
  • Re: two identical monitors: FWIW, I use the laptop display (MBP 15") and 2 different external monitors -- one LG, one Samsung, both connected via CalDigit TS3+. I regularly see the desktops associated with the laptop display and the LG switch. (Planning to try displayplacer, thanks.) – Peter Cardona Sep 13 at 12:22
3

Apple Support helped me out with this:

  • Go to the Finder (click on desktop) and then hover over the "Go" menu at the top of your computer screen
  • Now press the "option" button while still hovering over "Go" and you will see the "Library" folder choice appear
  • Choose "Library" by highlighting it.
  • With the Library folder open in front of you, locate the "Caches" folder.
  • Now drag it to the trash.
  • Empty the trash.
  • Restart.

Eureka! This solved this annoying screen switch problem for me in mission control, where my Mac desktops would automatically switch by themselves when working in one of the four open Mac desktops.

  • Just tried this, hopefully it will work as this happens to me every time my Mac sleeps! – Josh Cole Oct 31 '18 at 10:57
  • 1
    This doesn't work for me. :( – SpaceDog May 29 at 8:56
  • Doesn't work for me either. :( – ForeverWintr Jun 15 at 19:03
1

What seems to work for me so far, after one week of trying, is simply connect each monitor to an USB-C port on a different side of the laptop.

0

I've got a display-setup with two identical displays connected via two separate HDMI-Adapters in two separate USB-C ports. My Macbook Pro is always connected to the displays and whenever it wakes up from sleep-mode, the displays-arrangement is mixed up. My solution until this day was to rearrange the displays via "System Preferences". Now I'm using aveneyer's displayplacer-solution in combination with a shortcut setup to launch a shell-script in Keyboard Maestro and it works like a charm on Mojave!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.