I accidentally changed the UniqueID of my main disk drive with with the diskpart utility and now my OS won't boot. I get a BSOD error code 0xc000000e.

Here are the command I ran in diskpart:

list disk
select disk 0
uniqueid disk ID=some gibberish I typed

How do I revert back to the old UniqueID settings of my HDD? I don't want the data in it. I just want a working PC again. The thing is, I inserted a Windows 8 to do a clean install but it won't even recognize the drive, saying that a media drive is needed.

  • If your computer can't boot and you can't boot to a CD/DVD or USB then it may be because you have "Secure Boot" enabled. When you turn your laptop on does it say "Press [x] to enter setup..." or something similar that will allow you into your BIOS? – Kinnectus Jul 27 '16 at 11:25
  • @BigChris The thing is, when I inserted the CD and got past the "press any button to proceed..." part, the Windows 8 installator told me that there are NO hard disks on my PC, which is odd... I was about to request a hdd change if it wasn't for my brother who found another w10 installation disk which I tried. Weird thing, it recognized my hard drive and so I could reintall my os and boot the thing up again. It was a faulty disk, after all.. – Erecha Jul 27 '16 at 14:18

I simulated your situation in a virtual machine. The actual error that I received was 0xc000000e. (Notice the "e" at the end.) Please confirm because if one of my assumptions is wrong, the answer is wrong!

Unlike what you said, I successfully run Windows Setup without a problem. So, the most likely cause is that you did not give your computer an explicit command that says Boot from my Windows Setup media! This is especially correct if you do not see a message that reads "Press any key to boot from CD or DVD..."

So, once your computer is turned on or reset, repeatedly press Delete key to Enter your computer's BIOS Setup. (Your computer might need another key, like F2, F12, F8, etc. Check your computer's manual to find out or gaze at your computer's screen as turns on to see if it writes down the key that you need to press.) Once there, find a way to adjust the order of the devices that boot your computer. (Should be straightforward.) Make sure your DVD drive (in which you insert your Windows disc) is first. Alternatively, if your Windows Setup is on a USB flash drive, make sure that avenue has priority.

Once you get into Windows Setup, you can reinstall Windows... or change your UniqueID again. But I suspect you don't know your original UniqueID and there is no point going down that avenue.

| improve this answer | |
  • I confirm this, yes. That's the code I got. Anyways, I managed to do it getting a new Windows 10 cd and reformatting the entire hard disk. Thank you! – Erecha Jul 27 '16 at 14:15

What you've done by changing the UUID is cause the Windows Boot manager to not know where the disk to boot from is.

It is quite a complicated process to try and recover from this but what you can try to do is slave the computer hard disk into another PC and look at the registry to see if the original disk UUID is still there. If you can get this then you can put it back by using the command you used to break it in the first place.

This microsoft support article offers a similar scenario and how to fix it:


There is no guarantee that this fix will work for you.

| improve this answer | |
  • I went through all the trouble listed on this website, and it is dated and meant for MBR. The bcdboot for example is on the EFI partition of the boot drive, which doesnt have a drive letter initially. Even if you do load the hive from the bcdboot from the EFI when you go to the registry it doesn't list the old UniqueId, instead it has the new one listed. So I don't recommend this solution for trying to figure out what the old UniqueId was – ParoX Jun 17 '18 at 19:54

I just did the exact same thing as you did and after a few hours of research found something that finally worked and allowed me to restore my boot, keep my new UniqueID and without any data loss.

What was special about when I changed my UniqueId compared to a lot of dated resources was that it was GUID Partition Table (GPT) instead of a Master Boot Record (MBR). You will know its GPT because the uniqueId would of been something like 37650a7f-fb49-4fad-8040-b5f303e4f676 instead of something like a4e19dc0.

I struggled finding information on how to fix my boot because now a days Windows 10 has new commands and or motherboard/harddrives almost always use UEFI and GPT.

  • Insert the Media (DVD/USB) in your PC and restart.

  • Boot from the media. (May require you to go into BIOs and select the boot device)

  • Select Repair Your Computer.

  • Select Troubleshoot.

  • Choose Command Prompt from the menu

Type in the follow commands:

List disk            (Note which disk is your Boot drive number mine is 0)
Sel disk 0
List vol               (Note which volume is the EFI partition mine is 4)
Sel vol 4
assign letter=V:

After you have assigned a drive letter Using Diskpart You can format the EFI partition:

format V: /FS:FAT32

Then redo your UEFI using this new command for Win 10 1709 (This use to be bootrec /fixboot but that was not successful and returned an "access is denied" for me)

bcdboot C:\windows /s V: /f UEFI
| improve this answer | |
  • You don’t actually have to format the EFI partition for this to work it worked for me just fine! – Matt Aug 2 '19 at 10:51

I just did this by accident. Wanted to change the Volume ID and managed to change the Disk ID and got the same error. Win7 64 bit. Booted to the install media and ran a repair. The repair found startup errors and said it fixed them. Works fine now.

| improve this answer | |

Ive been looking into this quite abit recently its seems windows will return errors and wont boot if it believes if doing so will in danger physical hardware. as of so you went ahead and changed the GUID also known as the Global Unique Identifier. If you change this and if it doesn't correspond with the UUID set on the Bios which the UUID can only be changed by flash hardware then to protect any faults or damage windows will not reboot. I did further tests by actually changing the Guid then changing the GUID back to the original after the change without booting and it still refused to boot. even repairing it with windows 10 installer on a 32GB Sandisk (FAT32) did not work. if you want to change the GUID i recommended just changing the hard drive instead. the UUID is hard coded to the motherboard attempting to change this or change apart of it may and can damage hardware beyond repair.

I did this research in connection of misuse of third-party clients game software for anti-cheat systems. we used the UUID and GUID to ban Machines from accessing clients networks/Servers and clients games.

| improve this answer | |
  • Thanks for sharing your research; however as evidenced by the accepted answer it's not true that changing the hard drive is necessary to resolve this problem. – I say Reinstate Monica May 22 '18 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.