4

I hate to ask the same question in multiple places, and I asked for the same question at the Skype community forum, but the answer at that forum just suggested that, unfortunately, there is no way to disable the feature I wouldn't like to use. So probably I'm looking for an alternative way.

Recently I've found that my Skype application profile directory is quite big. Analyzing the directory structure of my Skype profile discovered an usually big size of %USER_PROFILE%/AppData/Roaming/Skype/.../media_messaging/emo_cache_v3 -- about 128MB. The directory contains really a lot of image files (about 4.5K), and I don't see why do I need them to be deleted knowing that I have never used any of them. Ok, I've moved JPEG, PNG, and the _distr files out of that directory to make a cleanup. Once I click the smileys button the in the chat window, I get some now images downloaded again. No... I don't want to use enhanced emoticons ever, and don't want my profile directory to be stuffed with such images. Well, I really can't see any particular reason of why I might be interested to use them.

Is there any way to disable the enhanced emoticons and stop them to be downloaded forever? However, I would like to keep all standard yellow smileys. The only way I'm thinking at the moment is a scheduled job to make a sort of cleanup right there, but I cannot see how to identify and not to delete "not standard yellow" smileys.

  • 1
    applies to Mac Os version of Skype too (~/Library/Application Support/Skype/username/media_messaging/emo_cache_v2). – kolen Sep 21 '16 at 21:56
  • 1
    If you are still around here on SU, you could try marking the images folder as "read-only", it might crash skype, but it also might resolve your problem – Ferrybig May 3 '17 at 10:32
  • Try changing the config/preferences 'Messaging' tab, 'Emoticons: Don't show/Standard/Animated', and delete the cache first. Also, always always when reporting Skype issues, tell us the Skype version, since it's constantly changing, adding bloat and breaking things. – smci Sep 2 '17 at 13:13
3

The solution for MAC OS (tested with v10.13.2 and Skype Version 7.59 (37))

  1. Quit Skype
  2. go to /Users/username/Library/Application Support/Skype/skype.id/media_messaging
  3. remove folder emo_cache_v2
  4. create 0 Byte file with exact same name emo_cache_v2 (!NOTE: not a folder, but a file without an extension)
  5. run skype

The solution for Windows (tested on Windows 7 x64)

  1. Quit Skype
  2. Go to you %USER_PROFILE%/AppData/Roaming/Skype/.../media_messaging/
  3. Remove any of maps like: emo_cache_v2
  4. Create empty files with filename(s) of the removed folders
  5. Start Skype - All clean now

This will not give skype the permision to create those folders and show any nonsense media on the main page, thus it will not download anything and will save on disk space.

This will also keep the standart animated smiles, but will block searches on animated GIFs and Mojis.

0

The size of Skype's emoticon cache emo_cache_v2 directory depends on the Skype options/preferences 'Messaging' tab, 'Emoticons: Don't show/Standard/Animated' (both Windows and MacOS).

Close Skype, delete emo_cache_v2 then open Skype, and change in your options/preferences 'Emoticons' from 'Animated' to 'Standard'.

I confirm (for Skype v7.6) that doing this reduced my emo_cache_v2 size from

'Animated': ~200M of animated PNGs
'Standard': ~7-18M of non-animated PNGs (yes it varies!)
'Dont show': 19M of PNGs (Yes it makes no sense that 'Dont show' > 'Standard')

So set 'Emoticons' to 'Standard'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.