0

I'm trying to pair my Xbox One (Model 1697 1697-IL) controller with the wireless adapter for some time now without much success. It works just fine when plugging in via an USB cable.

If I check the device managers status, the device status is:

This device is working properly.

But under the Events tab I see that the first event is

  • Device not migrated

This is the full log of the event:

Device USB\VID_045E&PID_02E6\026243 could not be migrated.

Last Device Instance Id: USB\VID_2717&PID_0360\D76AF11 Class Guid: {36FC9E60-C465-11CF-8056-444553540000} Location Path: PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(2)

Followed by these events:

  • Device configured (oem2.inf)
  • Device started (mt7612US)
  • Device installed (mt7612us.inf)

It was also not working on Windows 8.1 before. I'm now running Windows 10, wanted to upgrade any way but I've read that the Win 10 support for the Xbox controller is supposed to be better - or not...

I've tried to figure out what exactly a possible cause of the message in the event could be but couldn't find anything meaningful out.

I've tried plugging the adapter in different USB ports (v3 and 2) already. I've upgraded the controllers firmware by connecting it with an USB cable. I'm running the latest driver version. I've tried an older version as well - still no success.

My installed driver appears as "Xbox Wireless Adapter for Windows" in the device manager and the version is 21.50.45.656 from 2015-12-08.

Any other recommendations?

  • Xbox One or 360? – Kaizerwolf Jul 28 '16 at 18:03
  • How can I identify this? I'm using the one I've got with my Oculus Rift. Edit: Found it in the battery bay: Xbox One. – burzum Jul 28 '16 at 18:03
  • It appears to ship with an Xbox One controller. – Kaizerwolf Jul 28 '16 at 18:06
0

This thread from Reddit may help you. It appears that the Xbox One controllers can utilize two drivers; Xbox One Controller, and Microsoft Xbox One Controller.

The thread has other troubleshooting steps, but the two main (and most popular/successful steps appear to be as follows)

Method 1

Open Device Manager
Right Click "Xbox One Controller"
Select Update Driver Software
Browse
Let me pick
"Microsoft Xbox One Controller"

Method 2

Follow method one.
Unplug and plug your Xbox one controller
Open "set up usb game controllers". Fastest way to open that is to 
type that to the start menu.
Select Xbox controller from list and press "Properties"
On "Settings" tab press "Reset to default" button
Check your controller inputs from "Test" page and hope it works (Z Axis should move when pressing left trigger)

Hopefully this helps. If not, there's something else awry, and other troubleshooting may be needed.

EDIT: Per the asker's request;

I'm not sure if this solved it or if it was just a weird side effect of changing the drivers version forward and backward again. When connected via USB cable it said "Xbox controller", changed that to "Xbox gaming device", unplugged the USB cable, and the wireless stuff started to work for whatever reason... No idea why!

  • What exactly is the driver named? I see that I have "Xbox Wireless Adapter for WIndows" and the version is 21.50.45.656 – burzum Jul 28 '16 at 18:18
  • This is the part where my knowledge isn't so great, since I don't have the Oculus/Xbox One combo, so I can't recreate anything or corroborate on information. Sorry. :\ – Kaizerwolf Jul 28 '16 at 18:23
  • I'm not sure if this solved it or if it was just a weird side effect of changing the drivers version forward and backward again: When connected via USB cable it said "Xbox controller" changed that to "Xbox gaming device" unplugged (!) the USB cable and the wireless stuff started to work for whatever reason... No idea why! – burzum Jul 28 '16 at 18:26
  • The answer to that could just be, windows 10? :) – Kaizerwolf Jul 28 '16 at 18:42
  • I'm pretty happy with it so far. :) I don't mind flagging your answer as correct if you would just update it with the info from my previous comment? It was not the wireless but the controller driver itself for me for some magic reason. It might help other people as well or give them at least another thing to try. – burzum Jul 28 '16 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.