9

In both Windows 10 and Windows Server 2012R2, I am missing my C: drive (which is Hard Drive 0 or Disk 0) from the Performance tab in Task Manager.

This used to work with Windows 8.1.

Task Manager

Comparison of 8.1 (left) and 2012R2 Task Managers, on 2 different systems. They both have a C: drive though.

How can I configure the Performance tab to also show information for the first drive?

Update: Waid Johnson's answer worked well for one of the systems I am looking at. The system that is not working has Intel Rapid Storage Technology enabled, and there is a cache on Disk 1 that caches Disk 0.

2
7

Only drives that have Write Caching enabled will show up in Taskmgr. So open device manager, select the drive, go to the option and activate write caching.

enter image description here

enter image description here

4
  • Thanks for this! I never checked the Device Manager. Now I see that my disk 0 is missing, I only see disk 1. I never checked since my C: partition of disk 0 is very much present in explorer. I will investigate if that is due to Intel RST SSD caching and some glitch there. – Andreas Reiff Jul 30 '16 at 10:22
  • I will accept since this helped me to solve my problem. (Thanks @Waid Johnson again too!) After finding out that the device was missing from device manager, I uninstalled the Intel SATA controller and disabled the SSD cache of RST. After a reboot, disc 0 was in device manager again and also in task manager performance tab. After reenabling SSD cache, it has remained there, so it is working well enough. – Andreas Reiff Jul 30 '16 at 11:18
  • 1
    i have this enabled on both of my drives and its still missing, win2012 r2 – acme64 Oct 6 '17 at 13:45
  • 1
    @acme64 server hide it by default. Run diskperf -Y to enable it. this is not required for client systems, only for server. – magicandre1981 Oct 6 '17 at 14:48
14

Try giving this a shot:

  1. Ensure Task Manager is closed.

  2. Launch the Command Prompt using the Run as Administrator option.

  3. Enter the following at the Command Prompt:

    diskperf -Y
    
  4. Hit Enter.

  5. Close the Command Prompt.

  6. Re-open the Task Manager.

5
  • 2
    Thanks for the answer. Unfortunately, this has not changed anything. – Andreas Reiff Jul 29 '16 at 18:50
  • 2
    It did not work on Windows 10, it worked for the Windows 2012R2 system though. I will update the question, perhaps there is a link to Intel RST (SSD cache for C: drive) on the Win 10 system. – Andreas Reiff Jul 29 '16 at 18:58
  • 1
    worked for win2012 r2, thank you. – acme64 Oct 6 '17 at 13:47
  • 1
    Works on Server 2016 as well. – Robbie Crash Apr 10 '18 at 2:55
  • 1
    also worked on server 2019 – goodhyun Jan 3 '20 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.