1

Sevral years ago, I uninstalled every one of my internet browsers on a laptop running Windows 7 Home Premium version 6.1.7601, installed in 2011.

I now want to install a browser - any browser - onto the laptop. However, I can't figure out how to install a browser without having a browser.

Internet Explorer is completely uninstalled. FTP commands through Windows Explorer (such as found in question 302602) are not working either. I used to have Chrome as well as Firefox, but those were both completely uninstalled.

My laptop has good internet connection, and can run Outlook and many programs (though not all) when it is in a good mood.

NOT A DUPLICATE OF:

How can I download and install a browser on a new installation of Windows 7E? - that refers to Windows 7E and the solution doesn't work on my version.

How to get a web browser without one - ftp commands aren't working

  • Use a USB drive? I know this isn't all too helpful, but it really sounds like you need to re-install your OS. – Josh Jul 29 '16 at 21:48
  • Hmm. What is question 302602? and 12786? Please edit your question and include proper links. – DavidPostill Jul 29 '16 at 21:59
  • Erm Click the link icon when editing your question? Press <Ctrl>+<L>? Read Markdown help?. – DavidPostill Jul 29 '16 at 22:11
  • 1
    Out of curiosity... how are you posting on this site if you don't have a browser? If you have your phone you could download firefox or chrome binary on your phone and transfer it to your pc... – Darius Jul 29 '16 at 22:46
3

It's not possible to completely uninstall Internet Explorer from Windows 7; it can only be disabled so it doesn't look like it's installed.

To bring it back, go to the Control Panel and open Programs and Features. Then, select "Turn Windows features on or off". Internet Explorer should be in the list. Just check it and hit OK. Once it's done it should prompt to restart the computer.

This assumes that you didn't use some kind of hack tool to remove it. If that's what you did then you'll have to download a browser somehow, either on another computer with a USB flash drive (the easiest way), or use FTP to grab it from Mozilla or wherever. You said you tried FTP but you didn't say exactly what the problem was.

  • It is then neccesary to restart the computer - that took me a while to figure out! Please add that to your answer. – user6595 Aug 1 '16 at 0:53
  • If you had removed IE entirely, I'm wondering if running Windows Update would get it back for you? – Cand3r Aug 8 '16 at 16:17
6

Just use Chocolatey. It's a package manager for Windows, just like apt is for Linux.

Install it using this command in prompt:

@powershell -NoProfile -ExecutionPolicy Bypass -Command "iex ((new-object net.webclient).DownloadString('https://chocolatey.org/install.ps1'))" && SET PATH=%PATH%;%ALLUSERSPROFILE%\chocolatey\bin

It's useful to enable Global confirmations:

choco feature enable -n allowGlobalConfirmation

Then, all you have to do is type in prompt:

choco install googlechrome

And it's done. Simple, easy and fast!

4

Assuming a vanilla Windows 7 installation, you have at least PowerShell 2.0. It can download files, although slightly complicated:

If you just need to retrieve a file, you can use the DownloadFile method of the WebClient object:

$client = New-Object System.Net.WebClient
$client.DownloadFile($url, $path)

Where $url is a string representing the file's URL, and $path is representing the local path the file will be saved to.

Note that $path must include the file name; it can't just be a directory.

It would be written like that:

$client.DownloadFile("https://download-installer.cdn.mozilla.net/pub/firefox/releases/47.0.1/win32/en-US/Firefox%20Setup%2047.0.1.exe", "D:\\Firefox Setup.exe")

Note how backslashes need to be escaped by a backslash. If it immediately displays an error message, check that the target location (D:\ in my example) is writable by the current user.

Make sure to also read the other answers over there, because it’s a lot easier on PS 3.0.

  • Thanks! I tried this on 2 different versions of PowerShell and got the FullyQualifiedErrorID: DotNetMethodException – user6595 Jul 31 '16 at 22:43
  • ...with the message being? You did create the object first, right? – Daniel B Jul 31 '16 at 23:11
  • Exception calling "DownloadFile" with "2" arguments: an exception occurred during a WebClient request. At line:1 charachter:21. CategoryInfo: Not specified: (:) [] , MethodInvocationException – user6595 Jul 31 '16 at 23:57
  • It’s most likely a permission error or URL typo. Double check everything. If it still doesn’t work, update your question with the command you tried. You can also further inspect error messages using the built-in $Error array, like so: $Error[0] | Format-List -Force. – Daniel B Aug 1 '16 at 5:34
0

Boot a live Linux disc

start a terminal

install wget:

sudo apt-get wget

Then download firefox

wget https://download-installer.cdn.mozilla.net/pub/firefox/releases/47.0.1/win32/en-US/Firefox\ Setup\ 47.0.1.exe

Copy it to a memory stick and then onto the PC. Or better still install Linux on the PC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.