11

I installed Windows 10 in virtualbox on my macbook and now speakers and mic are not working with win 10. My problem is mainly with speakers.

2
  • Try to use the Audio Driver ICHA97, boot Windows with Driver Signature enforcement disabled and install the Audio drivers from intel.
    – Steven
    Jul 30 '16 at 15:38
  • How to do that? I can change driver but i do not know how to do the other thing.
    – Dušan
    Jul 30 '16 at 15:41
16

had a similar problem (audio cracking/not working); what worked for me (Xubuntu as Host, VirtualBox 5.2.14) I found on stackoverflow marked off-topic:

  1. VirtualBox - open the settings for your Windows 10 machine
  2. Go to Audio > Audio Controller, change to 'ALSA Audio Driver' and "ICH AC97" as Controller
  3. Boot your Windows 10 machine and disable driver signature enforcement
  4. Go to Realtek website, download and install the AC'97 audio codec/driver for Vista/7 ("Vista/Win7 (32/64 bits) Driver only (ZIP file)") onto your Windows 10 machine (run setup.exe)
  5. Reboot Windows 10
7
  • I don't see an ALSA audio driver in my settings, but I do have ICH AC97. Should CoreAudio work? Installing the AC'97 codec hasn't had any effect.
    – Merchako
    Dec 19 '18 at 22:35
  • 4
    Here's the link without having to give RealTek your email... https://realtek-download.com/wp-content/uploads/2014/07/6305_vista_win7_pg537.zip
    – Wil
    Dec 28 '18 at 0:51
  • Worked for me. I found that for Skype, I had to further select the Microphone (Realtek AC '97 Audio) from a dropdown list-- originally, it was set to "Phone Line". Jul 26 '19 at 20:12
  • For step 3 open command prompt and run bcdedit /set testsigning on and then restart the machine. Oct 28 '20 at 14:40
  • 1
    I have Windows 10 as a host, didn't fix the cracking issue. Oct 28 '20 at 14:43
3

Combination that worked for me (Ubuntu Host, Win10 guest) :
In Win10

  • install realtek driver In virtualbox
  • Host audio driver : PulseAudio
  • Audio Controller: Intel HD Audio
-1

I got it to work by:

  1. Follow the answer by definitely undefinable
  2. Before rebooting, opening the windows device manager (Win + R, enter devmgmt.msc and press Enter)
  3. Find the Multimedia Audio Controller in one of the categories. It should be displayed as missing a driver (yellow exclamation mark in the icon)
  4. Right-click on the listing and select Update Driver Software...
  5. Select Browse my computer for driver software
  6. Browse to the unzipped Realtek driver folder. Make sure Include Subfolders is checked. Press Next.
  7. Select Install this driver software anyway.
  8. Reboot the VM.

I furthermore had to change the Virtualbox settings back to PulseAudio, as I am using this on my Ubuntu 18.04 setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.