The Windows 10 "anniversary update" is coming out tomorrow and according to some reports the group policy to disable the lock screen is no longer effective on anything below the Enterprise edition. I'd like to know what options/workarounds are left to disable this nonsense on Pro editions.



2 Answers 2


For Anniversary Update Builds

There is a workaround to disable the Lock Screen in Anniversary Update builds, in any edition of Windows.

Create a Scheduled Task that runs the following command-line, or a batch/script that runs the following command:

reg.exe add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\SessionData /t REG_DWORD /v AllowLockScreen /d 0 /f

The idea is to reset the AllowLockScreen value data to 0 on these two trigger events:

  • Log on
  • Workstation unlock.

So you need to use multiple triggers for that task.


Download the Task XML from here: How to Disable the Lock Screen in Windows 10 Anniversary Update (1607)?

And use the Import Task option in Scheduler to create/import the task automatically.

Lock the workstation and unlock it. From the 2nd time onwards you shouldn't see the lock screen.

For Pre-Anniversary Update Builds

Start Regedit.exe and go to:


Create a subkey named Personalization

Select Personalization and in the right-pane, create a REG_DWORD value named NoLockScreen and set its value data to 1.

Exit the Registry Editor.

This registry edit corresponds to the following GPO.

Computer Configuration > Administrative Templates > Control Panel > Personalization > Do not display the lock screen

  • I can confirm this does work, if you're creating the task manually make sure to make it run as the "SYSTEM" user instead of your own account. Aug 6, 2016 at 16:01
  • 3
    This works when I manually lock the computer, but on every boot the lock screen still shows.
    – oKtosiTe
    Aug 13, 2016 at 16:57
  • Don't use this scheduled task! It's dangerous! I installed it and then my computer was almost broken. It could no longer log off or shut down. After restart, Explorer was constantly crashing until the system locked completely. I needed to delete this task with regedit in safe mode, now it works again.
    – ygoe
    Sep 12, 2016 at 6:56
  • 2
    I agree with @oKtosiTe in that it only seems to affect the lock screen when locking / unlocking, not on boot. I can't imagine why Microsoft thinks the lock screen is a good idea. Oct 1, 2016 at 3:11
  • The boot “lock” screen is different. It isn’t associated with a session. That’s also why Spotlight (the image changer thingy) doesn’t work there.
    – Daniel B
    Dec 20, 2016 at 9:15

EDIT: Below method didn't really work well for me in the end (the "boot case" still shows the lock screen), but I'll leave it here for the record and in case someone has some idea how to improve it.

An alternative method (not needing a Scheduled Task) seems to be:

  1. Start/Windows menu → type secpol.msc then press Enter;
  2. In tree pane on the left, select Software Restriction Policies (node 6 of 9 total) → Additional Rules;
    • if you don't see it, select menu ActionNew Software Restriction Policies to create it.
  3. Right-click on the right pane (with "Name", "Security Level", etc) → New Path Rule, then:
    • In Path, paste: C:\Windows\SystemApps\Microsoft.LockApp_cw5n1h2txyewy
    • Make sure that Security Level is set to Disallowed;
    • Click Ok.

Source: ghacks.net

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .