6

I had Windows 10 on my client machine and just made a fresh new installation. The server is a Linux machine where I did not change anything.

Since I made the fresh installation of Windows 10, I have troubles accessing my network drives. It takes up to 1 minute until the explorer windows loaded the content of the drive. It is not, that the drive just needs to start. I had this before as well and usually takes 3-5 seconds and not only one minute. I can also here it, when it starts ^^

A problem which I identified is, that even the windows of "My computer" is not showing the "used disc space" of the drives. When this is loaded, I can usually access the drives immediately. But after a couple of minutes doing nothing, I need to wait again that long.

The green bar in the explorer showing as well and I always have to wait until it's done.

Picture 1: "My Computer" while the network drives are not loaded "My Computer" while the network drives are not loaded Picture 2: "My Computer" when the network drives are loaded and I can access them "My Computer" when the network drives are loaded and I can access them Does anyone know why this is happening? I went fine before I reinstalled the windows.

2

Many people point to Windows caching as the problem. You can turn off the caching by changing the registry keys below. You can create and run a .reg file with the following contents or manually editing the settings in regedit:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
"DirectoryCacheLifetime"=dword:0
"FileInfoCacheLifetime"=dword:0
"FileNotFoundCacheLifetime"=dword:0

And FYI the defaults are:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
"DirectoryCacheLifetime"=dword:10
"FileInfoCacheLifetime"=dword:10
"FileNotFoundCacheLifetime"=dword:5

From https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-7/ff686200(v=ws.10)

| improve this answer | |
  • 2
    Has anyone experienced any benefits from this? I think this article may be a little out-dated – Jon Jul 10 '19 at 16:13
0

Some things to try:

Remove Remote Different Compression.

  1. Press the Windows key on the keyboard.
  2. Type "Turn Windows features on or off" without quotes in the search box and hit Enter.
  3. Remove the check mark next to "Remote Differential Compression".

Clear DNS Cache.

  1. Press Windows+X, click or tap Command Prompt (Administrator).
  2. Type the command ipconfig /flushdns and press Enter.

Also this registry fix might do the trick:

Regedit

  • Search for Key:

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
    
  • Add:

    DirectoryCacheLifetime Dword=0
    FileInfoCacheLifetime Dword=0 
    FileNotFoundCacheLifetime Dword=0
    
| improve this answer | |
-1

You can refer this link for list of possible steps you can do . https://www.zubairalexander.com/blog/creating-folders-or-accessing-files-on-remote-computer-is-very-slow/

| improve this answer | |
  • 5
    Welcome to superuser. On Stackexchange, we want complete answers, and links only as reference. – davidbaumann Apr 16 '18 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.