I have putty set up to use the monokai colour scheme via a .reg file found here

This works when creating new SSH sessions using the GUI. However, sometimes I like to start PuTTY from the command line instead:

C:\putty.exe -ssh user@ip -pw password

When I try to connect using that method the colour scheme no longer loads and defaults to the base PuTTY colour scheme, which I find fairly unusable

Whats the correct way to set the PuTTY colour scheme to monokai, so that it will load correctly regardless of which method is used?


You cannot set color scheme from command-line.

But you can save your preferred color scheme to the "Default Settings" in PuTTY. It will then be picked up for the ad-hoc sessions invoked from a command-line.

  • Configure your preferred defaults on the PuTTY configuration window
    (or just load the imported "monokai" session);
  • Go to "Session" page;
  • Select "Default Settings";
  • Press "Save"
  • Thanks. Is there a mapping anywhere of the colours found in the reg file to which variables they map onto in putty colour settings? – Simon Aug 3 '16 at 7:44
  • Hardly. But you can just import the .reg, start PuTTY, load the "monokai" session and save it as "Default Settings". – Martin Prikryl Aug 3 '16 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.