4

I have a fresh install of Windows 10 Home x64. This machine is used as a host for a VirtualBox VM (Ubuntu 16.04.1 x64).

All nice and good until I realized that when I press the win key on guest (fullscreen) it opens the dash menu as expected but it also opens the windows start menu. It also happens to open the start menu on host when I press win + d to show desktop on guest. Basically, any combination of win + anything opens the start menu on host which is really annoying.

Here are some links related to my problem but none of them seems to fix my problem: 1 2 3

I need to mention that I don't want a solution like, replace the super key in guest or permanently disable super key on host, or just get rid of VirtualBox and use VMware. I just need it to work as expected.

I have tried the AutoHotKey on host but it seems that is not applying the script for VirtualBox. It works if I restrict some key to Notepad but using the same script for VirtualBox only creates a delay for that key.

Any help will be highly appreciated!

  • Isn't there a menu option in the Virtualbox menu Input > Keyboard? – SPRBRN Aug 3 '16 at 7:16
  • 2
    @SPRBRN Yes, there is this menu option. However, i tried to deactivate the "Auto Capture Keyboard" but the problem persists. – Laur Aug 3 '16 at 7:24
  • Sounds like a VirtualBox bug, which has been know , to have problems with Windows 10 for whatever reason – Ramhound Aug 3 '16 at 7:48
  • Check here: superuser.com/a/1491888/14475. Actually, this "Auto Capture Keyboard" must be switched off, then on again. At least I did it and it solved the problem. – RedGlyph Oct 13 at 16:25
2

I finally found a solution, so I will answer my own question. It seems that if I start the virtual machine as Detachable Start, the win key or win key + any other key will not be captured by host.

However, the current version of the user manual (https://www.virtualbox.org/manual/ch08.html) says that:

Starts a VM with detachable UI (technically it is a headless VM with user interface in a separate process). This is an experimental feature as it lacks certain functionality at the moment (e.g. 3D acceleration will not work).

Most probably, the user manual is currently outdated considering that 3D acceleration is working properly with detachable start. Also, I haven't found any bug until now (1 day of usage) using the detachable start. My current version of VirtualBox is 5.1.2

  • Unfortunately this did not help. (on Ubuntu 17.10) – Oliver R. Jan 4 '18 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.