1

I'm trying to setup a few keyboard shortcuts that will let me ALT+TAB in to specific applications. I know I can use the command wmctrl -a "- Google Chrome" to do the actual switching, but I'm having trouble wiring it up to a keyboard shortcut.

The obvious option would be the "Command" section of the CompizConfig Settings ... only that doesn't work. No matter what keyboard shortcut I set, when I press it nothing happens (it doesn't invoke the specified command).

So, I'm either looking for:

A) an alternate way to specify a global keyboard shortcut (In Linux Mint MATE)

B) a way to debug/fix my CompizConfig Settings so that my Commands actually work.

Any help with either would be appreciated.

1

In MATE:

  1. Go to: Menu > Preferences > Keyboard Shortcuts
  2. Click Add (at the bottom of the window)
  3. Enter a name (like "Switch to Chrome")
  4. Enter the command exactly like you had it (wmctrl -a "- Google Chrome")
  5. Click Apply
  6. Click the "Disabled" text to the right of the newly created custom shortcut
  7. Enter the desired keyboard shortcut

In Cinnamon:

  1. Go to: Menu > Preferences > Keyboard > Shortcuts > Custom Shortcuts
  2. Click Add custom shortcut (at the bottom of the window)
  3. Enter a name (like "Switch to Chrome")
  4. Enter the command exactly like you had it (wmctrl -a "- Google Chrome")
  5. Click Add
  6. Double-click one of the unassigned keyboard bindings
  7. Enter the keyboard shortcut
2
  • Perfect, except under MATE you can find "Keyboard Shortcuts" under Menu > Preferences > Keyboard Shortcuts. From there (ie. from step #2 above onward) everything works great. Thanks! Aug 29 '16 at 23:45
  • 1
    Thanks for the feedback. I updated the post to include both MATE and Cinnamon instructions. Aug 30 '16 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.