0

I got the Windows 10 Anniversary update today and I'm excited to try the new Linux subsystem on windows. I previously have Cygwin installed on windows 10. So when I run bash from the command prompt, It directly launches cygwin instead of trying to install the Linux Subsytem for windows. Would uninstalling Cygwin help?

  • 1
    Have you installed the feature? It's not installed by default. – Ramhound Aug 3 '16 at 19:09
2

If you invoke where bash in the command prompt, you will find that the Cygwin /usr/bin or similar was found in your PATH. In fact, where might even find two bashes, one from Cygwin and another from Bash for Windows.

The fastest, simplest way to resolve this problem is to remove Cygwin from your PATH environment variable. With your command prompt still open, run systempropertiesadvanced, click on Environment Variables... on the bottom right, find the Path entry in the System variables list, click Edit, and remove the part that includes Cygwin.

If this still seems too complicated for you, use a program like Rapid Environment Editor that makes this a painless, hard-to-screw-up process.

Also, don't forget to actually install Bash for Windows as a Windows feature (thanks Ramhound).

  • I removed the Path entry for Cygwin. But now the bash command is not recognised. I'm confused? Do I need to download Linux subsystem seperately? – Vivek Vijayan Aug 3 '16 at 19:16
  • @VivekVijayan Yes, you'll need to install it separately. – oldmud0 Aug 3 '16 at 19:17
  • Actually I got it. I have to enable it from the features! Thanks a lot! – Vivek Vijayan Aug 3 '16 at 19:17
  • @VivekVijayan You need to install it. See the link in the answer. – DavidPostill Aug 3 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.