27

I updated my Windows 10 system to the 1607 "Anniversary Update" version and I can't find the Ubuntu Bash console.

So... Where is it?

  • I guess it's integrated into CMD/Powershell ?! – NetwOrchestration Aug 3 '16 at 19:24
  • 1
    Not really an "Ubuntu" console - it's a bash shell session, which is available on all Unix/Linux platforms. – SnakeDoc Aug 3 '16 at 22:49
  • 1
    This may be pretty off-topic, but what is so infamous about it? – Mayukh Nair Aug 4 '16 at 10:15
40

To enable the bash shell from the Windows 10 Anniversary Update, you have to enable the feature Windows Subsystem for Linux

1. Go into the Control Panel and click Turn Windows features on or off enter image description here

2. Then select the package Windows Subsystem for Linux (Beta). It will go through the installation process and ask you to restart your computer. enter image description here

3. Once it's restarted, you can search for bash in the search bar. enter image description here

| improve this answer | |
  • 2
    And so I did. Now when I click on the bash command a window pops up for a milisecond and disappears. Any ideas how to debug it? When I type bash in cmd, I get Unsupported console settings. In order to use this feature the legacy console mu st be disabled.. Is it somehow connected? Should I disable cmd? If so - how to do it? – Marek M. Aug 3 '16 at 20:20
  • @SzwornyDziąch what happens if you go into cmd and type bash? Does it prompt you to install Ubuntu? – DrZoo Aug 3 '16 at 20:25
  • That exact message appears. I tried disabling cmd as described here: maketecheasier.com/disable-command-prompt-windows and it's disabled now. However, that did not fix the problem. Btw, I had a short lag after clicking the bash command and so I could see that the same message appears. – Marek M. Aug 3 '16 at 20:27
  • 1
    @SzwornyDziąch re-enable cmd and disable cmd's legacy mode. To disable legacy mode, open cmd, then right click in the title bar and select properties. Then uncheck use legacy console. Here is a pic – DrZoo Aug 3 '16 at 20:31
  • 4
    @SzwornyDziąch no problem. Glad it's working for you. Have a bashing good time! Heh, I made a funny. – DrZoo Aug 3 '16 at 20:35
16

I think you need to switch to developer mode as well.

enter image description here

| improve this answer | |
  • 2
    That might be true. I've been in developer mode for a while, so I didn't know about that step. I'll have to turn it off and see if I can still access bash. – DrZoo Aug 3 '16 at 23:52
  • 3
    I confirmed that you do have to be in developer mode. Upon switching modes, I could no longer access the bash feature. – DrZoo Aug 4 '16 at 2:04
  • Yeah, I was prompted to do that when I did it too – Journeyman Geek Aug 4 '16 at 2:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.