2

When I try to start my newly created virtual machine on a fresh install of Virtualbox I get the following message.

Failed to open a session for the virtual machine Debain. The virtual machine 'Debian' has terminated unexpectedly during startup with exit code 1 (0x1). More details may be available in 'C:\Users\me\VirtualBox VMs\Debian\Logs\VBoxHardening.log'.

Result Code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine { ... somecode }

I tried the following things

  • Disable guest network adapter
  • Adding all Virtualbox processes to the windows firewall exception
  • Removing my antivirus
  • Reinstalling Virtualbox (with and without cleaning my registry in between)
  • Changing the system type of the guest
  • Booting with / without the Debian iso installer
  • Starting with every possible combination in the Virtualbox guest settings
  • [Edit] Checking out my XML file; http://bit.ly/2aPfWmt

Finally, starting the VM in Headless or Detachable Start makes it work just fine. I can then Show the VM without a problem. Debian is installing right now. I can even switch to scaled or fullscreen modes without a problem (had errors with previous versions of Virtualbox)

I have the following information for you

  • Windows 7 64-bit
  • Intel i7 3630QM + 8GB RAM
  • nVidia GeForce 680M + Intel HD 4000 (nVidia Optimus)
  • Virtualbox 5.1.2 r108956
  • VT-d is enabled in BIOS

This pretty much sounds like a bug in Virtualbox, but I have not been able to find anyone else reporting this. Does anyone have any theories about what may be going on? How is the regular start different from the Headless/Detachable, even though the GUI works after the VM has started?

  • you may need to fix xml file bit.ly/2aPfWmt – mussdroid Aug 3 '16 at 22:59
  • I also found this but forgot to add it to my tried list. My Debian.xml is in the right place and looks just fine. Thanks for your suggestion though. – Losmoges Aug 6 '16 at 10:48
  • I am facing the same problem, when I was in windows 10 it worked fine for me but when I install win7 then my VM not starting in normal mode. what is the fix for it? – subhashis Mar 27 '18 at 2:08
  • I eventually solved it by trying different (older) versions of Virtualbox – Losmoges Jun 20 '18 at 7:57
  • Experiencing similar problem. Seems to be the most recent version of Virtualbox. Likely should go as a bug report to Oracle rather than StackExchange. – user34445 Feb 12 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.