When I try to turn on my laptop for some reason it is not booting, but last night it was working just fine.


  • Pressing the power button does nothing
  • I tried to boot it without the battery
  • The screen light does not work at all
  • Nothing but an empty black screen
  • I hear no warnings beeps at all

When I close the lid and check the backside, the CPU has heat and feels very hot, and the fan is working.

What should I do?

  • What is the make and model of this laptop? Pull out the battery and disconnect the electrical cord and then hold down on the power on/off button for 30 seconds. Take a can of compressed air with it still unplugged and no battery and then blow the air through every hole you can find. See if that makes a difference to start. You may consider taking the enclosure off and exposing the Motherboard to look for damage from heat like swollen capacitors, soot, etc. Start with the easy stuff first though to eliminate that as the cause... The make and model would be helpful to disclose. Aug 4, 2016 at 3:51
  • "feels very hot". How long was it on for? Where exactly are you feeling- the air exhaust, the bottom of the laptop, or directly on the heat pipe? How long was the laptop "on" (fan spinning) before it starts getting hot
    – Blaine
    Aug 4, 2016 at 4:25
  • @Blaine boot on about 2 minutes, the screen keep black, so i pressed power button forcefully close the laptop, open it from backside and reboot it again, after about 10s fun on, then i touched heat pipe directly, its very hot
    – JustWe
    Aug 4, 2016 at 4:53
  • @PIMP_JUICE_IT the laptop i bought it from infamous local company.
    – JustWe
    Aug 4, 2016 at 5:06
  • How long have you had it since you purchased it? Did they give you a warranty? Do you have compressed air to try what I stated in the first comment? If they are infamous, then why would you purchase in the first place? Aug 4, 2016 at 5:11

1 Answer 1


The problem is my SSD did not set properly.


I removed each component one by one and tried to boot laptop. Finally when I removed SSD and boot, then screen shown BOOT DEVICE NOT FOUND, so I put SSD again, it got work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .