2

I'm trying to assemble a bootable RAID1 for Linux on ASRock Z170 Extreme 7+ with 2 x SSD Samsung 950 Pro NVME connected directly to M.2 ports using Intel Rapid Storage Technology in UEFI.

I was carefully following the instructions as per this article and managed to set up RAID1 in UEFI no problem. However, after this done, nothing appears in the boot menu after restart. Debian 8.5 installation / partitioning does not detect any drives either.

This is my UEFI settings:

  • Boot CMS: enabled
  • Launch Storage OpROM Policy: UEFI only
  • SATA Mode Selection: RAID
  • Storage OpROM Policy: UEFI only
  • Intel Rapid Storage Technology: RAID1(Mirror), Bootable

And this is my hardware setup:

  • ASRock Z170 Extreme 7+, UEFI updated via Internet Flash
  • Intel Core i5 6400
  • 32GB DDR4
  • 2 x NVME SSD Samsung 950 PRO connected to M.2 ports.

Switching Launch Storage OpROM Policy to Legacy makes Intel Rapid Storage Technology (and my RAID1) to disappear from the Advanced settings.

Switching SATA Mode Selection to AHCI makes SSDs perfectly visible by both UEFI Boot Manager and Debian, but separately, not as a single drive RAID1.

RAID detection issue with Windows could be easily solved by installing Intel RST drivers during Windows instillation. But Linux?

What am I doing wrong? I would appreciate any ideas.

  • May a tad obvious question: But tje linux kernel you are trying to boot has support for AHCI. Does it also have support for NVME? If not, can you load the relevant module or build a moinolithic kernel which includes the driver? – Hennes Aug 4 '16 at 14:40
  • Thanks for pointing out the direction! Looks like you are right. I will try adding updated kernel and UEFI bootloader. I'll keep this post updated. – Romario Aug 4 '16 at 14:51
  • @Romario were you able to get this solved? – Jeffrey L. Roberts Jan 11 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.