5

I have several installations of FF (2 desktops, 1 laptop, 2 Android).
All of them use the same sync account and the same master password.

Bookmarks sync fine between all the devices.
Passwords sync fine between the desktops/laptop devices.
Passwords on the Android devices do not sync.

Please help!

  • Same problem here. I don't even have a password option on the sync page (I have bookmarks,history,open tabs and logins). I'm using the latest firefox. – user115145 Aug 7 '16 at 11:08
8

Do you use the master password feature on the Android devices? If yes, the passwords won't sync --- it's a known limitation. Workaround: You can disable the master password feature, then wait for (or force) a sync event and then reenable the master password feature. It worked for me that way. (At least it worked for the profile managed by the release channel of Firefox for Android; on a second Firefox installation, with Firefox for Android beta, it did not work this way.)

References: https://support.mozilla.org/en-US/kb/firefox-sync-troubleshooting-and-tips#w_im-unable-to-sync-my-passwords-in-firefox-for-android

|improve this answer|||||
  • 1
    Still accurate as of Jan 2018. Thanks for the workaround! – ncoghlan Jan 21 '18 at 3:27
  • This method does not work for me. I have changed my Google password on a desktop. Both desktop FFs synced. I removed Master Password on Android FF, then resynced manually twice. I even did a phone restart. Then resynced again. Firefox 64.0.1 on Android 8.0.0 still shows old password. – Combinatix Jan 5 '19 at 7:44
  • @Combinatix : Yes, I've also remarked that in the builds from the last weeks. Every few weeks (2 months or so) I used to temporarily disable the master password on the Android Firefox in order to fetch the latest additions/changes made on the desktop browsers' profiles. Some time ago this workaround ceased to function. I was about to report (or check whether it was reported) to Mozilla.In the meantime, it seems that it was solved in 64.0.2 – paul-emil Jan 13 '19 at 18:21
  • @Combinatix : The real reply (due to that 5 min. comment update limit) [...] I was about to report it to Mozilla and check build by build (or commit by commit) to spot the regression source. In the meantime, it seems that it was solved in 64.0.2 (rel. on 2019-01-09) and also in 65.0.b9 (β9, 2019-01-08), even if the release notes don't mention it, nor there is a bug report (update) on this annoyance that I could find on Bugzilla, like the bug #1013064 or others. – paul-emil Jan 13 '19 at 18:42
  • I have uninstalled the FF from my Android and then I did fresh install. I have no Master password now and the problem is gone. – Combinatix Mar 5 '19 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.