3

When working I will have multiple windows of file explorer open at a time. If I than start working on something else and leave those windows open in the background, they will close themselves leaving only one of them open. I have tried going into task manager and restarting file exploiter and that didn't fix it. i am running Windows 10 pro. Does any one have any ideas on how to fix?

Thank you!

  • You can try to use the Windows Event Viewer to try and trace the error. Open the run dialog and enter: eventvwr.msc Then, go through your Administrative Events and look for related errors. – picobit Aug 4 '16 at 20:24
1

Possibility #1

If the folder is deleted or moved explorer windows will close themselves. Are these folders being manipulated in anyway?

Possibility #2

The other possibility is explorer having too many files open at once. A good fix for this is to enable "Launch folder Windows in a separate Process". It's a little know feature of windows that allows the machine to separate file/folder access from the Explorer GUI process (been around since XP).

It can be found under Control Panel > File Explorer Options > "View" Tab > Launch folder Windows in a separate Process

Possibility #3

Alternatively, you can check to make sure that explorer hasn't become corrupted.

  1. Launch an administrator commandline (Win + X) -> Press "A"
  2. Click yes to accept the UAC prompt
  3. Type this command "sfc /scannow" (without the quotes)

Windows will scan all of its core files and fix any problem it finds. I am an IT professional and explorer generally starts to behave after theses steps have been exhausted.

  • Awesome, thank you! I will try these we a get a chance and get back to you. – Austin Salisbury Aug 4 '16 at 20:17
1

If there's a network glitch, where a local Windows Explorer senses that a Network Share is no longer available, the OS WILL close Windows Explorer which was previously viewing said share. No error, no warning. 100% frustrating. Most users would prefer seeing an error with a REFRESH / RETRY option.

1

The simple fix is to set the Drive Map GPO to use the Action UPDATE.

To stop your mapped drives disappearing or automatically closing:

Launch Group Policy Managementnetwork-mapped-drives-closing-spontaneously-automatically Find your drive mapping GPO, right click on it and select EDIT Expand USER CONFIGURATION > PREFERENCES > WINDOWS SETTINGS > DRIVE MAPS Double click on the drive map that is automatically closing Change the ACTION drop down from REPLACE to UPDATE

  • This is only the solution if network drives are the issue and they are being mapped by group policy. There's nothing in the question that indicates this is the case, and the accepted answer does not note this solution. This is good information, but it is not the answer to this problem. – music2myear Sep 4 '19 at 2:40
0

I've had some users complaining about this happening. After seeing the issue by myself, I started searching for the cause. I opened three Explorer Windows, one with the local C: drive, one with the profile mapped homeshare and one with the commonly used data storage share drive.

The only window, which was closing occasionally, was the one with the common data storage, which lead me to the conclusion, that I should have a look at the GPOs.

Forcing a GPUPDATE reproduced the issue and I started searching on the net where I found this thread here.

The solution was exactly what user1084330 described. Setting "Replace" to "Update" on the affected GPO solved the issue at the second GPUPDATE.

0

I had the same issue on a users machine, every time he opened file explorer it would just crash. He did get an Intel Optane error at first but after I uninstalled Intel Optane and rebooted that error went away, but the initial problem still persisted.

I eventually fixed it by setting explorer to open "This PC" instead of "Quick Access":

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.