2

I have Windows 7 x64 (built 7600).
I just installed Firefox 3.6 and I set it as my default browser, upon I've set that all of my HTML files were been without any icons!
Could you please guide me how I can fix HTML files' icons when FF3.6 is my default browser?
Thanks.

P.S:
Whenever I set IE8 as my default browser the HTML files' icons were fixed.

1
  • Whenever this happens, I uninstall Firefox and reinstall it from an installer.
    – endolith
    Jul 18, 2013 at 15:22

4 Answers 4

3

I just installed Firefox 3.6 and am also seeing this behavior. I actually hadn't noticed until you brought it up, to be honest.

So what we're going to do is work with the registry, a la the instructions provided here. Essentially we're going to force HTML files to display an appropriate file type icon. I will edit this answer with more details in a few minutes after testing the technique.

UPDATE

First off, that technique should work, and the keys you should be looking for are HKEY_ROOT\.htm, HKEY_ROOT\.html and HKEY_ROOT\FirefoxHTML.

However, I'm noticing that I already had HKEY_ROOT\FirefoxHTML\DefaultIcon configured, and even after configuring HKEY_ROOT\.htm and HKEY_ROOT\.html as well (all to use Firefox's executable icons), and rebooting, and manually rebuilding the icon cache, I still have blank icons.

I'm not forced to believe that the issue is with the Firefox executable itself. However, you may have better luck specifying a .ico file.

4

Here is what fixed this annoying issue for me. I'm on a Windows 7 64 bits, and I use Firefox as default browser.

  1. open regedit from Win Menu\ Run
  2. go to HKEY_CLASSES_ROOT\FirefoxHTML.
    • That registry key will be different if you default to Chrome. In order to know which key to go to, check the predefined value in HKEY_CLASSES_ROOT\.html and HKEY_CLASSES_ROOT\.htm
  3. Within that FirefoxHTML (or equivalent one), under ShellEx key there should be an IconHandler key
  4. Just rename that last one, e.g. prefix it with an hyphen (-IconHandler) so to disable the HTML icon special treatment and revert to default icon string value.

HTH

3
  • 1
    This worked also in Windows 10 (upgraded from Win7).
    – antak
    Aug 1, 2016 at 1:55
  • Mine has no IconHandler key :(
    – primehalo
    May 18, 2017 at 22:50
  • 1
    I had the same issue after uninstalling Office 2010 on Windowns 8. Deleting the IconHandler key worked.
    – akinuri
    Sep 12, 2017 at 12:18
1

Firefox icon missing in Windows 7 x64: https://support.mozilla.com/en-US/forum/1/481472 "Peter" has a registry fix there

2
  • Thanks Ramesh, I've followed the link, but it doesn't work for me! Mar 15, 2010 at 19:21
  • Link doesn't work anymore
    – primehalo
    May 18, 2017 at 22:52
1

This is how i fix this issue:

Windows 7 x64 with Chrome 68.0.3440.106 (Official Build) (64-bit)

  1. Open regedit
  2. Go to HKEY_CLASSES_ROOT\ChromeHTML\DefaultIcon
  3. Edit Default–in the right panel
  4. Copy chrome.exe path: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" and paste into Default
  5. Click OK, then Refresh/F5
  6. Voila!

Hopefully this help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.