4

After the last anniversary update of windows 10 (of august 2) hyper-v fail to start any of the virtual machine, new or old.

The message I get is "Virtual Machine Name" failed to start worker process: An invalid HANDLE was specified. (0xC0000008).

Error dialog

I have try many thinks, and look all over the internet bug I can not find solution.

  1. I have totally remove and re-install the hyper-v
  2. I have check for correct permissions on the directories of the vm
  3. I have run Process Monitor to see why is crash
  4. I have read the debug report that send to MS
  5. I have made from scratch new test virtual machines, for both generations.

after all that is still not runs...

Any idea is appreciate.

2

I have the exact same issue and also found no solution jet.

I've also installed the latest BIOS - no success.

My specs are: - Win 10 Pro (Build 1607) - MainBoard: ASUS X99 Deluxe - CPU: i7-5820K

I'll check my drivers now and then I'll give the SFC a try...

Edit1:

Updated / Re-Installed some drivers now - no success

SFC running..

Edit2:

SFC had no success eighter.

Edit3:

I found that COMODO Internet Security is the problem at hand. Uninstalling it & rebooting fixed the issue. But with no virus protection left, this isn't a good solution.

At the COMODO Forum there is a thread for this issue, too. We should wait what COMODO finds out: https://forums.comodo.com/bug-reports-cis/comodo-firewall-began-conflict-with-hyperv-t116351.0.html

13
  • I have made the same with no success either – Aristos Aug 15 '16 at 13:13
  • Can't believe that we're the only two having this issue. It's sad that there is still no solution for this. I don't want to re-setup the whole host mashine -.-... – Khaos Aug 31 '16 at 8:42
  • I can not agree more with you. And even if you re-setup the system I am not believe that the issue will go. – Aristos Aug 31 '16 at 9:38
  • Ok. I found some posting saying, that Comodo Anti-Virus can be the problem. I'll check this myself now. Do you use Comodo, too? – Khaos Sep 1 '16 at 15:33
  • 1
    Uninstalling COMODO & restarting the computer fixed the problem! – Khaos Sep 1 '16 at 15:45
1

I had exactly the same issue with a test virtual environment in Hyper-V which was working perfectly on my Windows 10 machine.

I installed Intel Unite Software on my PC and could no longer start any Hyper-V VM. I then uninstalled this software it began working immediately. I would recommend uninstalling any non-vital programs you've installed recently, prior to when Hyper-V stopped functioning.

I am looking into this software to see what component caused this and will update if I gent anything more useful. Hope this helps.

0

Today Comodo Firewall update their drivers inspect.sys and was signed by Microsoft, and hyper-v starts working again with out the above message.

The working Comodo Firewall version on files is 8.4.0.5165

0

I had the same issue, uninstalling mirrorop virtual driver resolved this issue. I think every virtual driver can result in this kind of issue.

1
  • what is that driver ? where and how you uninstall it ?, please give some more informations - this error by the way was a problem coming from comodo firewall and now have been fixed. – Aristos Mar 14 '17 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.