2

I am trying to dual boot windows and linux by putting my second ssd in this optical drive caddy. However, the caddy is not recognized by the BIOS. As far as I can tell from this site, I am running the latest version for my model (v1.21).

When I turn on the computer, the blue light on the caddy lights up so I am assuming there is at least getting stata power if not data. Did I get a bricked caddy? Unfortunately I do not have another laptop to test it in. The ssd works perfectly if I put it directly in the hard drive slot.

Any suggestions?

  • 1
    put the SSD in the internal HDD slot and the old HDD into the caddy. The caddies often only use SATA2/3Gbit – magicandre1981 Aug 8 '16 at 5:20
  • same happened to me with an Aspire 5740. putting HDD into the caddy helps. – conquistador Aug 8 '16 at 10:53
  • @magicandre1981 Both my ssds are sata 3. I have tried with both in the caddy. Isn't sata backwards compatible? – Marcel Aug 8 '16 at 19:28
3
+50

There are a few reasons this could happen:

  • Check the power requirements of the SSD. The optical drive caddy uses a slimline SATA power connector, which is shorter than a normal SATA power connector and doesn't have the 3-volt and 12-volt lines that a normal SATA power connector has. The slimline variant only uses the 5-volt line. If your SSD needs the 3-volt line, it won't work. The power requirement should be on the label or in the box it came in.
  • Optical drives are inherently SATA-1 devices because they don't need the bandwidth that SATA-2 and SATA-3 provide. The SSD, on the other hand, does require SATA-3 speeds. Your model laptop came out right around the time SATA-3 was becoming a thing, so I don't know if it has SATA-3 ports or not. But this could be the issue if the firmware won't accept a high-speed device on the opti-bay's connector (or if the drive doesn't handle a SATA-2 port properly). You can test this by hooking up your internal HDD to it and see if it works. If it doesn't, this is probably why. I've seen jumpers on spinning hard drives that you can use to limit their bandwidth to SATA-1 speeds, but I've never seen this on an SSD.
  • It's possible that the SSD is getting too much interference from nearby components. As stated previously, optical drives operate at SATA-1 speeds, so interference isn't as much of a problem for them as it would be for an SSD. This is an issue in older MacBook Pros, where the opti-bay SATA connector is right next to the Wi-Fi antennas. Some laptop models place the SATA connector right next to the CPU or the RAM, which are both high-speed devices. Most laptop manufacturers don't take shielding into consideration when placing components near the optical drive (not even Apple with their legendary build quality). And why would they? The interference is low enough for the optical drive to work fine, so that's all that counts as far as they're concerned.

Sadly, there isn't much you can do about any of these problems. Your best hope of getting it to work is trying as others have suggested in the comments; place the HDD in the caddy and put the SSD into the main drive bay. But if that doesn't work, you're out of luck.

| improve this answer | |
  • Thanks for the answer. I will try those suggestions and see how it goes. – Marcel Aug 8 '16 at 21:50
  • Does your BIOS have an option to disable the DVD/CD drive? How about an option to enable a Module bay? For my Dell laptop, disabling DVD and enabling Module pay in the BIOS let me run SSD with a caddie. – Peter Aug 9 '16 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.