I have a laptop with Windows 10 Enterprise edition installed (64bit).

I haven't got the Windows 10 Anniversary Update from the normal Windows Update (I have clicked Check for updates). So I want to install it manually.

I have downloaded the the update from the Microsoft page. However when I run it, the Update Assistant says

Windows 10 will not run on this PC Operating System: Contact your system administrator to upgrade Windows Server or Enterprise editions

But I'm my own system administrator. I've installed Enterprise Edition from MSDN Subscriber downloads.

How do I update to the Anniversary Edition?


4 Answers 4


To Upgrade the Windows 10 Enterprise Editions, get the 1607 ISO from MSDN/Volume Licensing portal, mount the ISO via double click on it, run the setup.exe on the virtual DVD drive, now select Upgrade

enter image description here

and next select Keep personal files and apps

enter image description here

This upgrades Windows 10 to the Version 1607 and keeps all installed Windows Applications.

  • 2
    I guess this is probably correct. Unfortunately, after I upgraded Boot Camp, the ISO led me to a full reinstall, all settings and apps lost. Lesson: don't upgrade Boot Camp Aug 7, 2016 at 12:43
  • Did the upgrade itself work, and was the Boot Camp upgrade separate? Aug 16, 2016 at 18:19
  • @LucasMcGraw First I started to do the Anniversary update, and it looked pretty much like this answer. Then I cancelled it (since it sounded like it would loose my sewtting). Then I upgraded Boot Camp separately (from 4 to 6). Then I no longer got the updgrade option above when trying to install the Anniversarhy update. Aug 17, 2016 at 8:57
  • this solution seems to be working for me but it would be nice to know why you have to do this and it doesn't work automatically through windows update (why the "contact your admin message")
    – coding4fun
    Sep 9, 2016 at 21:29
  • @coding4fun because it is a Volume License version and no retail / OEM Sep 10, 2016 at 5:25

I found a solution that actually works for Windows 10 Enterprise. Takes some tweaking and it will install Build 1607. Make sure you have a backup. Secondly make sure you are signed in with your Microsoft Account. Then follow these steps below.

  1. Open regedit.exe and navigate to HKLM\Software\Microsoft\Windows NT\CurrentVersion
  2. Change ProductName to Windows 10 Professional
  3. Change EditionID to Professional
  4. Navigate now to HKLM\Software\Wow6432Node\Microsoft\Wind­ows NT\CurrentVersion
  5. Change ProductName to Windows 10 Professional
  6. Change EditionID to Professional
  7. Close regedit.exe (no need to restart)
  8. Start the Windows 10 Pro installation from your installation media. (Download the Media Creation tool from Microsoft - http://go.microsoft.com/fwlink/?LinkId=691209 or https://www.microsoft.com/en-gb/software-download/windows10 and click on the Download Tool now)
  9. Do the upgrade, will download and install, keep all files & settings.
  10. Will reboot several times, once finished, log back in with your Microsoft Account and it will automatically link your enterprise key to the install and you will be back on Enterprise Edition and have Build 1607 installed.

I did it on 4 machines today and it worked every time.

  • 5
    are you serious? I wouldn't recommend that way.
    – Dom84
    Sep 26, 2016 at 9:00
  • Thank you very very much!!!! Even the Microsoft Support couldn't fix this problem. Sep 26, 2016 at 12:19
  • Didn't work for me :( The upgrade didn't have the initial error, but one screen in it said that an error occurred and wouldn't continue.
    – askvictor
    Oct 17, 2016 at 23:18
  • 1
    Not able to find productName under currentversion following 1st step itself. Where exactly its located? Oct 23, 2016 at 12:26
  • I could not get the tool to work but it got farther on each attempt. Eventually it failed with an error code that google suggested was related to downloading updates while attempting to install. Sure enough, the anniversary update downloaded in the background and installed succesfully.
    – Josiah
    Nov 22, 2016 at 14:40

Simply turn off "Defer Upgrades" option from the advance settings of Window Updates. Window Key> Settings> Update and security> Advanced option. then off the Defer upgrade. And again search for Windows Updates. You will get one.

  • I did not have "Defer Upgrades" set. Sep 25, 2016 at 10:19
  • Confirmed! It works as of now, I had it turned off.
    – Candide
    Oct 18, 2016 at 10:12

I 've struggling for a month. Today i got inspired and finally found the solution. My pc has windows 10 Enterprise installed which is domain joined. So when i am on Windows Update screen the Check box Check online for updates form Microsoft Update is unchecked. Check the box, update and during update recheck it.

enter image description here

  • Please read the question again carefully. Your answer does not answer the original question. The updates you show in your answer do not include he Anniversary Update
    – DavidPostill
    Oct 3, 2016 at 12:30
  • I know my intension was not to show the updates. But the check box. I have already installed it. I cannot rollback just to take a screenshot. Oct 3, 2016 at 12:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.