I have a new Dell Studio XPS laptop that I hooked up in early January of 2010.

The Dell Studio XPS laptop is connected to my wireless router (Belkin Wireless N). The router was purchased in Februari of 2010 because I thought my router was bad (A D-Link router). Comcast is my ISP.

Everyday, at random times, the internet will have a good signal (according to the little Win 7 icon on the taskbar) but I will receive a message saying limited or no internet access and I cannot access the internet.

I have the internet setup to automatically get an IP and I did the IPCONFIG release / renew but with no success.

I even had a WiFi enabled Blackberry right next to my computer and whenever the computer loses an WiFi connection, so does the Blackberry.

The router isnt't bad, because the old router did the same thing - giving me limited or no internet access while working sometimes.

I also tried using two other laptops in same physical position as my Dell Studio XPS laptop and they have the same problem.

I am going crazy trying to figure this out as I have called the router company (Belkin), my ISP (Comcast), and my computer maker (Dell).

Can anyone offer some suggestions and I can try them as we work through this and maybe one of the suggestion will be right one.

Thanks in advance for even reading my problem. I searched for a problem similar to mine on the internet, but I have not been able to keep a steady internet connection.

(Side note - I used to have an IBM thinkpad laptop and D - Link router and for years that wireless connection worked FLAWLESSLY, with the same physical set up - the laptop in my bedroom, and the router in the basement.)


I had a Dell 830 that had awful probelms with our wireless router, netgear, I had to statically allocate the IP address to get round the issue. (this is probably unrelated to the problem, it just still irritates me to this day)

Are there other wireless signals in the area, perhaps changing the channel will help. On the router you will be able to see, and change, which channel it uses.

  • I have just got back in from a night out so if you need me to explain better just ask. – Joe Taylor Feb 20 '10 at 0:15
  • Thanks for your help. I have about 6 wireless networks that my Dell is detecting. I am not quite sure how to change my wireless channel. There is only one button on the Belkin router and that is the button to "reset" the router. Thanks a million. – Anthony Trilussa Pizzo Feb 20 '10 at 23:16
  • In your router settings, usually under wireless settings, there will be an option to change the channel. My router has 13 different channels. Try changing it through the different channels and see if any work better for you. I am using a BT HomeHub for my home network, here is an image of the channel settings in there img59.imageshack.us/img59/6923/channelselect.jpg – Joe Taylor Feb 21 '10 at 10:01
  • hey - I ran the CD that came with my router and I manually changed the wireless channel from 6 to 8. Now the reponse time when I run a ping to ping -t from from an avergage of 300ms to 2ms to get a reply from the IP address. Is that good? Is that a 2ms normal? Thanks, any info on this topic you can give is greatly appreciated since I have never worked with truly manually setting up a router and changing channels. Thanks a million. (sorry for the delayed response, my internet was down for 3 days..let's hope this channel change is what saves my internet!) – Anthony Trilussa Pizzo Feb 24 '10 at 17:02
  • I usually get a response time of under 1ms. But 2ms isn't the end of the world. 300ms seems to imply that somethign was wrong, thats the kind of response time you'd expect pinging a remote site. the fact it was 300ms suggests something was wrong, perhaps interference, were you seeing any dropped replies? – Joe Taylor Feb 24 '10 at 17:42

Firstly, let's rule out the router/wireless as the problem.

  1. Click Start
  2. Type cmd and press Enter
  3. Type ping -t and press Enter (replace this IP address with your default gateway if this is incorrect)
  4. Minimize the command prompt and leave it running.

When you see the limited connectivity icon displayed in the system tray, immediately restore the command prompt running the ping. Note any lines that look out of the ordinary, i.e. not replying to the pings.

alt text

If you see 'timed out' or 'general failure' errors, we can safely determine that the problem is your router (as all devices are affected, not just your computer). Given the fact that you have historically had the same problems with different routers, I find it unlikely that this router is also playing up.

Otherwise (as I suspect), the problem is with your internet connection. You would really need to go back to Comcast technical support and advise them that you have tested pings to the router and they remain fine during the internet dropouts.

  • Hi here is the messsage I get when I run CMD and do a ping (sorry I tried to do a print screen but I didn't know how paste a picture on this site): Reply from bytes=32 time=9ms TTL=254 Reply from bytes=32 time=9ms TTL=254 Reply from bytes=32 time=9ms TTL=254 Request timed out. Reply from bytes=32 time=363ms TTL=254 Request timed out. Reply from Destination host unreachable. Request timed out. Request timed out. So judging from your comment, is this a router issue?Which is weird b/c both routers had this prob – Anthony Trilussa Pizzo Feb 20 '10 at 23:13
  • Hmm.. if you do ipconfig /all from the command prompt, what does it say your Default Gateway IP address is? – Kez Feb 20 '10 at 23:18
  • I'm guessing it's ? Can you do the ping again, but use this IP address. – Kez Feb 20 '10 at 23:34
  • Hi again! thanks for your patience. My internet was down for 3 days. So here is what I did... I did ping -t and got replys from that IP address whenever the internet was working. While the internet was down, I got this message "Reply from Destination host unreachable" (notice the IP address is different - it ends in 4 instead of 1). And then I will get 10 lines of "request timed out" and than the Destination host unreachable. That has happened for the past few days. Any advice on where the blame lies for limited access/no connection lies what be GREATLY apprec – Anthony Trilussa Pizzo Feb 24 '10 at 16:47
  • What is (or was) the IP from your own laptop. I guess that you where the – Hennes Feb 9 '16 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.