1

I successfully installed XAMPP on Mac OS X EL Capitan Version 10.11.1. Apache Server, ProFTPD and MySQL Database are running.

I followed XAMPP's How-to-guide to transfer files via the proFTPD server / configure FTP access, so I can also use a FTP client like Filezilla to access the htdocs/ subdirectory of the XAMPP installation directory.

As I'm the only user, I didn't create a group. I did however chown and chmod the directory so it is writeable and I'm the owner.

Host address: 127.0.0.1

Port 21

username = My Macbook account username (= the one shown to me when I use whoami using Terminal)

password = My Macbook account password

No typo. Everything appears to be correct. But I'm not able to connect.

Status: Connecting to 127.0.0.1:21...

Status: Connection established, waiting for welcome message...

Response: 220 ProFTPD 1.3.4c Server (ProFTPD) [::ffff:127.0.0.1]

Command: USER ******

Response: 331 Password required for ******

Command: PASS **********

Response: 530 Login incorrect.

Error: Critical error: Could not connect to server

When I enable remote access and then use FileZilla and SFTP, hostname also localhost, my username and password are accepted just fine. But in this case I can't see the htdocs folder at all. There's no /Applications/XAMPP/xamppfiles/htdocs/ directory to be found.

Is there something on Mac OS X EL Capitan that prevents access?

  • Since you are using port 21, check to make sure your port is open while running XAMP. There are online pages that check open ports if you don't have a tool for that. Also for FileZilla, make sure you are using the correct port and manually set it. Also make sure that you have port forwarding set up in your router.This may seem redundant, but you didn't tell us this in your question. – ejbytes Aug 7 '16 at 11:45
  • Did you setup your config in /Applications/XAMPP/etc/proftpd.conf. As stated here? kometschuh.de/XAMPPFTPConfigurtionMacOSX.html – mt025 Aug 7 '16 at 11:54
  • @mt025: I did update the proftod.conf file as well. – Croco2511 Aug 7 '16 at 12:10
  • Addition: When I enable remote access and then use Filezilla and SFTP, hostname also localhost, my username and password are accepted just fine. But in this case I can't see the htdocs folder at all. There's no /Applications/XAMPP/xamppfiles/htdocs/ directory to be found. – Croco2511 Aug 7 '16 at 12:14
  • "password = My Macbook account password" Are you sure ProFTPD knows your account's password? (Unlike Apple's built-in remote access, I'd expect that ProFTPD should not be able to get the password from the OS itself, so hopefully you should tell it your password if you want to use the same one.) – Arjan Aug 7 '16 at 12:41
1

Thanks to all for helping.

Editing the proftpd.conf file did not work nor did work following the steps listed in the how-to-guides that asks you to use Terminal to chown and chmod files.

That's what did work for me in the end:

Enable Remote Login for Mac user profile

Don't use FTP and Port 21, but only SFTP and Port 22

Use Mac username and password, Hostname is 127.0.0.1

In the Advanced Tab of Filezilla's Site Manager set Default Remote Directory to /Applications/XAMPP/xamppfiles/htdocs

The last step did the trick as before I only saw the Applications folder within my username folder but no way to access the main Applications folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.