0

So Windows has expired on me and it stopped booting today. When I tried to boot it up, it said that a component of my operating system has expired. So I thought that it would be a very easy fix, all I had to do was set the Hardware Clock in BIOS back in time to before Windows expired (7/15/16), and just upgrade it to the latest insider preview. The first time I did that, it worked, but Windows was strangely not recognizing my hard drive which I put a newer build of Windows 10 on it. But when I restarted my computer, it had a BSOD and a STOP code of "PROCESS1_INITILIZATION_FAILURE". So I checked my BIOS again, and this time, the time was set to the current date, and this is where my problem begins.

When I set the time in the BIOS back in time again, and rebooted, it gave me the same BSOD with the same STOP code. When I booted back into BIOS, the time was set to the current time, and obviously when I booted with it being set to the current time, instead of it crashing, it just told me that a component of my operating system expired.

So everytime I set the time in BIOS back, Windows just crashes, and somehow sets the hardware clock to present time.

The reason I think Windows keeps crashing is that it somehow knows what the time is, while not using the hardware clock, so then it updates the hardware clock, and when it tries to boot, all the certificates are expired and it gives me a STOP code.

I tried numerous things. Such as:

Running

bcdedit /set {default} useplatformclock true

On a bootable disk I had.

Then I tried loading the registry in, and I modified it so it doesn't automatically update over NTP, and I also stopped the W32Time service. I literally tried to do everything. I even set the date in the BIOS back, rebooted back to it to make sure it set, and yet Windows keeps updating it and crashing. And the worst part is, its so early in the boot process that it didn't save a crash dump or anything.

Tl;Dr:

Windows expired so I changed the clock in BIOS back in time so it would boot, but when I attempt to boot Windows, it crashes, and sets the time forward.

So I'm looking for a possible solution to how to make Windows think that it's before 7/15/16 if it's possible.

  • 3
    If it's connected to the internet, the clock will auto-update from NTP. You would at minimum need to block NTP, or disconnect the network entirely. – Tetsujin Aug 7 '16 at 16:17
  • No, I don't think that's it because it's so early on the boot process, it has to at least load the Wi-Fi drivers. But did turn if the Wi-Fi, set the date back in BIOS, and booted in Safe Mode, but it still sets the date in BIOS forward, and then crashes while it's booting up. Is there some file I can change to make it think that it's before July – Mike B Aug 8 '16 at 0:06
0

So after a lot of searching, I found this answer on Super User: https://superuser.com/a/988392

Turns out that there's this file called bootstat.dat. And this file, when I booted Windows up, reseted the time to present. So if anyone has issues with Windows expiring and when you change the date of the BIOS and when you restart, it changes back to the current date, just delete that file /Windows/bootstat.dat

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.